Support » Fixing WordPress » RSS feed showing full feed, even with it set to Summary

  • robbyyy21

    (@robbyyy21)


    I have an issue where my RSS feed is showing full content, even though I have summary checked in WordPress. Not sure of the reason.

    Was wondering how I can force the RSS feed to show just the first 40 words of an article only.

    Can I do this via the functions.php file in the active template?

    If so, what do i need to do? I have looked around the web and couldn’t find an answer.

    Thanks in advance!

    Best,
    Rob

    • This topic was modified 7 months ago by Jan Dembowski. Reason: Moved to Fixing WordPress, this is not an Everything else WordPress topic

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Joy

    (@joyously)

    The feed is cached, so if you looked at it, then changed to Summary and looked again, you won’t see a change.
    The theme doesn’t really do anything with the feed, but there are quite a few functions that are for the feed that you can filter.

    robbyyy21

    (@robbyyy21)

    Thanks – I have deleted all caches, but the change doesn’t take effect. Other changes do, like adding images to the feed.

    Joy

    (@joyously)

    I doubt you deleted the feed cache, since it is in the options table of the WP database.
    If you have an option to add images to the feed, that would come from a plugin, so perhaps that plugin is affecting your feed in other ways that you are not aware of.

    Thanks Joy – I’ll give that a go. I have been using db caching, but will check to see what else is going on.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘RSS feed showing full feed, even with it set to Summary’ is closed to new replies.