WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] RSS Feed Showing Error and Not Working

[Resolved] RSS Feed Showing Error and Not Working

  • I recently changed the theme for my blog and now the RSS Feed doesn’t work.

    I’ve researched and tried doing everything but still not luck.

    Link to my site feed: http://enwil.com/feed

    It shows the following error:

    This page contains the following errors:

    error on line 2 at column 6: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.

    What does it mean and what should I do? I installed ‘Fix My Feed RSS Repair’ plugin as well, but still doesn’t work.

    What could be the problem?

Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi
    Forum Moderator

    @esmi

    Can you replicate the problem using the default Twenty Thirteen theme with all plugins deactivated?

    Hi esmi,

    First I deactivated all Plugins. It still showed the problem.

    After that, I Activated the Twenty Thirteen theme and the problem was solved.

    Again after that, I Activated the Parent theme of my theme and still it worked, and there was no error.

    When I Activated the child theme, the problem showed up.

    So, I guess I have problem in the child theme. What could be the problem in Child theme?

    I have been experimenting with lots of action hooks and functions lately, in the child theme.

    esmi
    Forum Moderator

    @esmi

    My guess is that you have a leading blank line in one of your child theme’s template files.

    The functions.php in the child theme had a blank line in the beginning. What a blunder mistake.

    Thank you esmi. 🙂

    esmi
    Forum Moderator

    @esmi

    Glad I could help 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] RSS Feed Showing Error and Not Working’ is closed to new replies.