The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] RSS Feed Returns Error 404: Not Found (5 posts)

  1. comicref
    Posted 3 years ago #

    I can no longer get any RSS feeds for my website http://www.theredshtick.com. I've tried all the standard links (i.e., http://theredshtick.com/?feed=rss, http://theredshtick.com/?feed=rss2, http://theredshtick.com/feed.rss, etc.), but no dice.

    One feed validators indicates "Server returned HTTP Error 404: Not Found." Another validators says "It looks like this is a web page, not a feed. I looked for a feed associated with this page, but couldn't find one. Please enter the address of your feed to validate." It then shows some code with this line highlighted:

    FWIW, I had server trouble earlier this week. Site was down and came back up. When it did, the plugins folder had been duplicated (one named "Plugins" and another "Pluginsx," the latter containing all the plugin files). I fixed that, only to have a error caused by one of the plugins (a somewhat outdated jquery based one) which I had to completely delete.

    Now I can't get any RSS feeds. I've been told (by the folks at Media Temple, my host) it might be a cache issue, but I'm not running any cache plugins. I've been told it could be a permalink issue, but I haven't fooled with them. That was about all they had to offer.

    I'm not sure if reinstalling WP (3.4.2) would help. Any suggetsions?

  2. comicref
    Posted 3 years ago #

    BTW, I tried deactivating all the plugins and tested the feed. Still nothing.

  3. esmi
    Forum Moderator
    Posted 3 years ago #

    Your feed is at http://theredshtick.com/feed and it does have some minor problems. Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  4. comicref
    Posted 3 years ago #

    I figured out the problem. It was self-inflicted. I had turned off the rewrite in the .htaccess file (in hopes of solving thumbnails not loading on Facebook previews). That screwed up the custom permalinks. When I switched to default, they were fine, but custom broke the feed. I edited the .htaccess file back and the feed works with custom permalinks once again.

  5. Satri
    Posted 2 years ago #

    comicref, can you provide more info on what's in your htaccess to allow /feed to work? I have the same problem but don't know what to change in my htaccess to make it work :-)

    Here's my current htaccess:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Feed not found: illuminart.ca/feed Thanks a lot! -- Alex

Topic Closed

This topic has been closed to new replies.

About this Topic