Support » How-To and Troubleshooting » [Resolved] RSS Feed Problems

[Resolved] RSS Feed Problems

  • When I try to read my blog thru a RSS newsreader called NewsGator, it comes up with an error saying “The underlying connection was closed: The server committed an HTTP protocal violation.” It never did this until 2 days ago and now I can’t read my blog via my RSS reader, what’s wrong here?
    My blog is located at http://techblog.windowsatoz.com if that helps. Thanks.

Viewing 15 replies - 16 through 30 (of 36 total)
  • I have the same problem as budiselich. My host says it’s a wordpress issue… Can anybody help?

    Moderator James Huff


    Both of you, upgrade to WordPress v1.2.2


    Thanks MACMANX

    this problem still exists under certain conditions, even for the latest version of wp. if your wp is laid out with /index.php/ (just take a look at the urls of your links) you will have to hard code your RSS link to point to http://www.example.com/wordpress/wp-rss2.php (adjust the URL as needed. wp-rss2.php resides in the same directory as index.php)

    i’m fairly certain the value generated by bloginfo(‘rss2_url’) is a setting somewhere. anyone know where it is?


    for rss1 – open the file wp-rss.php from the wp root
    for rss2 – open the file wp-rss2.php from the wp root

    find (around line 9)

    header(‘Content-type: text/xml’, true);

    and replace with

    header(‘Content-type: application/xml’, true);

    this works, try validating:


    Many thanks, funkdub. That has fixed wp-rss2 and wp-commentsrss2.php on my wordpress blog.

    Unfortunately, the fix did not work for wp-rss so I have removed wp-rss from the meta links on the blog.

    Is this cause for concern? Are there some feeds that need wp-rss rather than wp-rss2?

    hmmm, depends where you are submitting too. most place take rss2 – but some still parse the original rss feed… are you sure you made the correct alterations in the file? / did you refresh / clear your cache when validating it?

    I have tried upgrading to version 1.2.2. I have also tried funkdub’s QUICK SIMPLE FIX : that did not work. How do I make the hard code changes that lowcommotion suggested? I have looked through the indes.php file and am not daring enough to make changes without knowing which line to change.

    I think I’m having the same problem as budiselich, except that when I try validating my feeds, the error message says that my XML declaration is on line 5, instead of 2.

    I have solved my problem. I found that the host I was using was interfering with the php script. They were inserting links in the footer and when they interjected the links, it invalidated the html. I switched hosts and now my feed validates. A great host I found from io_error: http://www.ioerror.us/ is http://www.asmallorange.com

    Thanks for all the help,


    I’m using Flock when I click the RSS feed it says “flock doesn’t know how to open this…the protocol isn’t associated with any program…” Isn’t it that Flock and wordpress are working together for something…why this doesn’t work for Flock (0.5pre)?

    Sorry everyone, I have to be specific I was referring to the RSS feed to the support forum here of WordPress.org

    Moderator James Huff


    What you are seeing is the recent implementation of the relatively new feed: protocol.

    See an explanation and removal instructions here: http://wordpress.org/support/topic/29291#post-164887

    validate your url using the rss validator, you might also try to show less posts on your rss-file.

    Can anyone help me to creat RSS Fee for my site ??
    how can i add RSS in my site

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘[Resolved] RSS Feed Problems’ is closed to new replies.