WordPress.org

Forums

[resolved] RSS Feed Problems (37 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    When I try to read my blog thru a RSS newsreader called NewsGator, it comes up with an error saying "The underlying connection was closed: The server committed an HTTP protocal violation." It never did this until 2 days ago and now I can't read my blog via my RSS reader, what's wrong here?
    My blog is located at http://techblog.windowsatoz.com if that helps. Thanks.
    Alex

  2. lbessant

    Posted 10 years ago #

    Might be an issue with NewsGator, perhaps? I just checked using RssReader (http://www.rssreader.com/) and it connected to the feed without any trouble at all....

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    I'm having the same issue, but not just with NewsGator. I've tried SharpReader and Sauce Reader and its not just my blog, all wordpress blogs in my RSS software are doing it, Any ideas? maybe a service pack 2 issue or a .net framework issue?

  4. Anonymous
    Unregistered
    Posted 10 years ago #

    my blog is in spanish... and the rss doesn't work...
    i try to see the file in explorer http://olivieri.tx.com.ru/wp/wp-rss2.php and it says that the á,é,í,ó,ú,..etc are no valid characters or something like that...
    how can i fix this??? help plz

  5. newuser
    Member
    Posted 10 years ago #

    My rss feeds aren't working in yahoo or in newsgator. They both state that it could not find a valid rss or rdf file.
    radio userland also can't read the feed "Can't subscribe to the channel. The most likely cure is to check the URL in a web browser and see if you can get it to read the feed. The following message probably won't help you figure out what went wrong, but we include it here because it might. "rssAutoDetect"
    "
    Any ideas?

  6. jpabad
    Member
    Posted 10 years ago #

    In looking at the result of my wp-rss2, I see that within content:encoded there is a <![CDATA[ before the actual blog content and ]]> after it. I don't see this on my friend's wordpress installation. I'm guessing he's not running full feeds.
    End result is the same though, I'm using sauce reader and i'm unable to read my rss feed or anyone else who is running WordPress. Which sadly, due to my evangelism is pretty much everyone who isn't on livejournal.
    Even though it looks like various readers are having problems, I'm going to pursue a resolution to this on the Sauce Reader forums in case its a problem with the program.

  7. Otherdave
    Member
    Posted 10 years ago #

    I'm having the same problem with Sharpreader as the original poster. Anyone found the problem yet?

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    I am also getting this problem. Feedster validates the feed, but Sharpreader doesn't like it. I sent a bug report to Carl Hutteman who wrote Sharpreader to see if he could shed some light on the problem

  9. Anonymous
    Unregistered
    Posted 10 years ago #

    I use NewsGator, and my feed used to work, but for the last couple of weeks it hasn't. I also get the error "Error: The underlying connection was closed: The server committed an HTTP protocol violation."

  10. Anonymous
    Unregistered
    Posted 10 years ago #

    I've got problems with 404s and feeds. The 2 default URLs (http://endeavour.zapto.org/astro73/blog/feed/rss2/ and http://endeavour.zapto.org/astro73/blog/comments/feed/rss2/) I have not changed, but according to my server they don't exist (and they don't, nor are they in my local clean copy).
    Does .htaccess need to be enabled and present for this to work? And if yes, what does it need to be?

  11. Anonymous
    Unregistered
    Posted 10 years ago #

    I'm pretty sure the problem is that the feeds are sending out a malformed HTTP header ("Last Modified" as opposed to "Last-Modified".) Anyone running the .Net framework 1.1 with SP1 will see this error.

  12. Anonymous
    Unregistered
    Posted 10 years ago #

    Yep - the post above got it right. Change the following code to fix the problem:
    Replace line 87 of wp-blog-header.php with:
    @header('Last-Modified: '.$wp_last_modified);
    Worked for me.

  13. Anonymous
    Unregistered
    Posted 10 years ago #

    I could be wrong, but I think that wp-1.2.1 addresses this.
    I have a newly-upgraded version of wp and it reads the correct "Last-Modified", not "Last Modified".

  14. Kelson
    Member
    Posted 10 years ago #

    It's still broken in WP 1.2.1, but fixed in CVS.

  15. oneafrikan
    Member
    Posted 10 years ago #

    Thanks guys - that worked for me with Newsgator.

  16. budiselich
    Member
    Posted 10 years ago #

    I am trying to validate my rss feed but having problems. Here are the errors I get:

    This feed does not validate.

    *

    Feeds should not be served with the "text/html" media type [help]

    *

    Your feed appears to be encoded as "utf-8", but your server is reporting "US-ASCII" [help]

    *

    line 2, column 0: XML Parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]

    <?xml version="1.0" encoding="UTF-8"?>

    Source: http://www.virtualtheology.org/wp-rss2.php

    1.
    2. <?xml version="1.0" encoding="UTF-8"?>

    Any suggestions?

    Mark

  17. lovepade
    Member
    Posted 10 years ago #

    I have the same problem as budiselich. My host says it's a wordpress issue... Can anybody help?

  18. James Huff
    Volunteer Moderator
    Posted 10 years ago #

    Both of you, upgrade to WordPress v1.2.2

    http://wordpress.org/development/2004/12/one-point-two-two/

  19. lovepade
    Member
    Posted 10 years ago #

    Thanks MACMANX

  20. lowcommotion
    Member
    Posted 10 years ago #

    this problem still exists under certain conditions, even for the latest version of wp. if your wp is laid out with /index.php/ (just take a look at the urls of your links) you will have to hard code your RSS link to point to http://www.example.com/wordpress/wp-rss2.php (adjust the URL as needed. wp-rss2.php resides in the same directory as index.php)

    i'm fairly certain the value generated by bloginfo('rss2_url') is a setting somewhere. anyone know where it is?

  21. funkdub
    Member
    Posted 10 years ago #

    QUICK SIMPLE FIX :

    for rss1 - open the file wp-rss.php from the wp root
    for rss2 - open the file wp-rss2.php from the wp root
    etc.

    find (around line 9)

    header('Content-type: text/xml', true);

    and replace with

    header('Content-type: application/xml', true);

    this works, try validating:
    http://www.funkdub.info/wp/wp-rss.php

    with:
    http://feedvalidator.org/

  22. llizard
    Member
    Posted 10 years ago #

    Many thanks, funkdub. That has fixed wp-rss2 and wp-commentsrss2.php on my wordpress blog.

    Unfortunately, the fix did not work for wp-rss so I have removed wp-rss from the meta links on the blog.

    Is this cause for concern? Are there some feeds that need wp-rss rather than wp-rss2?

  23. funkdub
    Member
    Posted 10 years ago #

    hmmm, depends where you are submitting too. most place take rss2 - but some still parse the original rss feed... are you sure you made the correct alterations in the file? / did you refresh / clear your cache when validating it?

  24. budiselich
    Member
    Posted 10 years ago #

    I have tried upgrading to version 1.2.2. I have also tried funkdub's QUICK SIMPLE FIX : that did not work. How do I make the hard code changes that lowcommotion suggested? I have looked through the indes.php file and am not daring enough to make changes without knowing which line to change.

  25. Avenir
    Member
    Posted 10 years ago #

    I think I'm having the same problem as budiselich, except that when I try validating my feeds, the error message says that my XML declaration is on line 5, instead of 2.

  26. budiselich
    Member
    Posted 10 years ago #

    I have solved my problem. I found that the host I was using was interfering with the php script. They were inserting links in the footer and when they interjected the links, it invalidated the html. I switched hosts and now my feed validates. A great host I found from io_error: http://www.ioerror.us/ is http://www.asmallorange.com

    Thanks for all the help,

    Mark

  27. sfong15
    Member
    Posted 9 years ago #

    I'm using Flock when I click the RSS feed it says "flock doesn't know how to open this...the protocol isn't associated with any program..." Isn't it that Flock and wordpress are working together for something...why this doesn't work for Flock (0.5pre)?

  28. sfong15
    Member
    Posted 9 years ago #

    Sorry everyone, I have to be specific I was referring to the RSS feed to the support forum here of WordPress.org

  29. James Huff
    Volunteer Moderator
    Posted 9 years ago #

    What you are seeing is the recent implementation of the relatively new feed: protocol.

    See an explanation and removal instructions here: http://wordpress.org/support/topic/29291#post-164887

  30. nieuws
    Member
    Posted 9 years ago #

    validate your url using the rss validator, you might also try to show less posts on your rss-file.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.