rss feed problem (6 posts)

  1. praymond
    Posted 8 years ago #

    Whenever someone clicks on the RSS logo you get an error page with the message "XML Parsing Error: xml declaration not at start of external entity
    Location: http://mysportsrumors.com/blog/?feed=rss2
    Line Number 2, Column 1:"

    and when i go to feedburner it can't locate the feed itself as well. there i get an error saying "The URL you entered does not appear to be a valid feed. We encountered the following problem: Error on line 2: The processing instruction target matching "[xX][mM][lL]" is not allowed."

    I'm also not able to validate the feed. i Get this msg "This feed does not validate.


    line 1, column 1: Blank line before XML declaration [help]"

    If anyone can offer anyhelp please do so, i'd like to get that working before i really start to post articles. The website is http://mysportsrumors.com

  2. bioipr
    Posted 8 years ago #

    i also have these boring problem with feeds, and waiting for help.

  3. sleeplessinDC
    Posted 8 years ago #

    I just started having this problem on one of my blogs after updating to WordPress 2.6. The parser problem is happening because somehow the XML declaration is starting on the second line of the file -- it should start on the first line. I have not been able to figure out why this is happening. I turned off all my plugins but still get this parsing error.

    The site URL is http://www.stcwdc.org/wdcblog/ This site is hosted by Corpsite.

    I have another site that is not having this problem--it is hosted by Dreamhost. http://www.stc-access.org

  4. sleeplessinDC
    Posted 8 years ago #

    I just found the solution. A combination of suggestions in another post and one I found myself. See http://validator.w3.org/feed/docs/error/WPBlankLine.html for information about having blank lines in your wp_config.php file that cause the XML declaration to begin on the second line.

    I took out all the blank lines in mine and still had the problem. Then I noticed that the line feed endings for my wp-config.php file were set to Windows CRLF. I changed that to Unix (LF) and now my RSS feed works. The file should also be saved as Unicode UTF-8.

  5. bioipr
    Posted 7 years ago #

    Oh, thank you for giving us a good news. I really hate this problem.
    Would you please explain it more clear? "the line feed endings for my wp-config.php file were set to Windows CRLF." What does it mean? How should i edit wp-config.php?


  6. bioipr
    Posted 7 years ago #

    sleeplessinDC, i checked all php files, and did like you said, but still the same, can you help me with this? http://www.bioipr.com

Topic Closed

This topic has been closed to new replies.

About this Topic