WordPress.org

Forums

RSS feed problem (7 posts)

  1. wiredkiwis
    Member
    Posted 10 years ago #

    I know this may be a long-shot but you never know.
    My rss feed was working but I hadn't checked it for a while and now its not.
    I am getting the following error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/meme/public_html/sailingholiday/wp/wp-blog-header.php:1067) in /home/meme/public_html/sailingholiday/wp/wp-rss2.php on line 19

    running wp 1.2.1
    Any ideas appreciated

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    You've just played with that file :)
    Download wp-blog-header.php
    Open it with Notepad or an equivalent
    Scroll to the end of the file
    Remove the whitespace after the ?>
    That should sort it :)

  3. wiredkiwis
    Member
    Posted 10 years ago #

    haha bloody whitespace :)
    Thanks podz
    looks like thats fixed something...but..
    now I'm getting:

    XML Parsing Error: xml processing instruction not at start of external entity
    Location: http://sailingholiday.wiredkiwis.com/wp/wp-rss2.php
    Line Number 2, Column 1:
    <?xml version="1.0" encoding="' . utf-8 . '"?>
    ^

    The comments feed is working but not the main one?
    ps: I removed the whitespace at the end of the rss file too but it didnt help this time. :(

  4. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Hmm...here's the top of my wp-rss2.php
    <?php
    if (!isset($feed) || !$feed) {
    $blog = 1;
    $doing_rss = 1;
    require('wp-blog-header.php');
    }
    header('Content-type: text/xml; charset=' . get_settings('blog_charset'), true);
    $more = 1;
    ?>
    <?php echo '<?xml version="1.0" encoding="'.get_settings('blog_charset').'"?'.'>'; ?>

    Yours look the same ?
    Ah.. this is 1.3 .. check that the xml version line is right at the top of the php file.

  5. wiredkiwis
    Member
    Posted 10 years ago #

    ok..I've tried un-doing everything I've done in the past week without any luck :) haha
    I also tried swapping the:
    <?xml version=\"1.0\" encoding=\"' . $charset . '\"?".">"; ?>
    to
    <?xml version="1.0" encoding="'.get_settings('blog_charset').'"?'.'>';
    to se if that would work but it didn't so I undid that also.
    I'm sure it wont be in the rss files as I havn't been playing in there ..yet! ;D
    Have to go out now but will have another go at it tonight.
    Thanks podz
    maybe its time for me to upgrade to 1.3 now anyway :)

  6. wiredkiwis
    Member
    Posted 10 years ago #

    Well after many hrs I still havn't fixed it....its FOOBAR*D :)
    I've replaced "wp-blog-header.php" & "wp-rss2.php" with the originals.
    The "wp-commentsrss2.php" is still working fine (thats whats odd).
    I also replaced the links in the index in case there was something mucked-up in there so thats original now too.
    After all sorts of fixes its still got the Parasing error :(
    XML Parsing Error: syntax error
    Location: http://sailingholiday.wiredkiwis.com/wp/wp-rss2.php
    Line Number 1, Column 31:<?xml version="1.0" encoding="'. UTF-8 .'"?>

    this is the out of the box code snip:
    <?php echo "<?xml version=\"1.0\" encoding=\"' . $charset . '\"?".">"; ?>
    so I don't know if this is the problem or if its something I may have in the head of the index?
    I'll just keep bashing away but if anyones got ideas I'm more than willing to listen :)

  7. wiredkiwis
    Member
    Posted 10 years ago #

    Ok I changed the error line to:
    <?php echo <?xml version="1.0" encoding="utf-8" ?>
    as thats what it looked like it was asking for. It makes the feed work but this hasn't solved it.
    I now have a non valid xhtml page :(

    No Character Encoding Found! Falling back to UTF-8.
    Line 5, column 61: there is no attribute "charset"
    ...a http-equiv="Content-Type" content="text/html" charset="UTF-8" ></meta>

    ok back to the beginning and try to solve the MF!
    great way to learn how it all works eh.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.