Support » Fixing WordPress » RSS feed not working – no “feed” directory

Viewing 7 replies - 1 through 7 (of 7 total)
  • No directories need to exist. There is something wrong with the rewriterules. I would recommend an upgrade to 1.2 so you can get the new rewriterules which will fix this problem.

    Fargon’s suggestion to update is always good advice.
    Your permalinks don’t work either. (try clicking on one of or your titles.)
    Setting “friendly URI’s” in your options is good and fine, but it won’t work correctly unless you put the text it outputs into your .htaccess file, which would reside in your root directory.
    Apparently there’s something wrong with the rewrite rules in one of the versions, which I didn’t know about, but I thought I’d mention something in case you forgot to put them in your .htaccess. Also, I think your host has to have the rewrite mod, which seems to be pretty standard.

    By the way, if you get frustrated you can (and probably should) just turn “friendly uri” off in your options until you can get it to work correctly. At least that way, people can make comments.
    For what it’s worth, I had trouble with my SE friendly URI’s on my last page (I didn’t use wordpress), and ultimately decided to just do without, as I can be quite lazy. Google still made with the friendly.

    Okay, I deleted the custom URI thing. The links on my titles are working, and I can leave comments. So that much is good. But when I click the link for the RSS2.0 feed I get an error page…
    An invalid character was found in text content. Error processing resource ‘http://www.dave.englund.name/blog/wp-rss2.php’. …
    <description>From ABCNews.com…
    I’ve got the right path now to the “wp-rss2.php” file in my blog’s root. But what’s up with the ABCNews thing??

    This is a really stupid feature of XML stylesheets that requires strict conformity to the XHTML rules, which don’ t allow special characters like curly quotes or certain kinds of apostrophes. I don’t know what to do about it yet.

    Okay you guys, I’ve updated from 1.2 beta to 1.2 production (mingus). Still the same problem. When I click on the link for the RSS feed I get…

    The XML page cannot be displayed
    Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.
    ——————————————————————————–
    An invalid character was found in text content. Error processing resource ‘http://www.dave.englund.name/blog/wp-rss2.php’. …
    <description>From ABCNews.com…

    So, what now? How do I get this RSS thing fixed??!!

    Can someone PLEASE help me find a resolution to this? My RSS Feed always worked fine in MT. Why the hassle in WP?

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘RSS feed not working – no “feed” directory’ is closed to new replies.