Support » Fixing WordPress » Rss Feed not working, can’t be found

  • I am having trouble with my RSS feed: its not even there.
    I have searched the forums for a solution and tried everything possible that I could find.

    The feed validator gives me this result:

    Sorry

    This feed does not validate.
    Server returned HTTP Error 404: Not Found

    http://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Fwww.main-trainer.de%2Fw%2Ffeed

    I have tried this without success:
    adding slashes to the default feed rules in config.php

    1. Open wp-config.php
    2. Remove any spaces after “?>” at the very end of the document.

    Create an empty plugins folder

    * Via FTP or your host’s control panel, navigate to the wp-contents folder (directory)
    * Via FTP or your host’s control panel, rename the folder “plugins” to “plugins.hold”
    * Via FTP or your host’s control panel, create new folder called “plugins”
    * Login to your WordPress administration menus
    * Via FTP or your host’s control panel, delete the empty “plugins” you previous created
    * Via FTP or your host’s control panel, rename “plugins.hold” back to “plugins”

    like I said, so far nothing has worked.

    I did have to write a .htaccess file because of wp being in a subfolder, maybe that is interfering with my feed?

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    AddHandler php5-cgi .php

    but I have done this before in another domain and it worked without problems….

    GARGHHHHH! Any help is HIGHLY appreciated 🙁

    (I’m on wp 2.9 btw)

Viewing 10 replies - 1 through 10 (of 10 total)
  • Are you using this statement? <?php bloginfo('rss2_url'); ?> I had trouble before when using <?php bloginfo('rss_url'); ?>

    Check also if wp-rss.php and wp-rss2.php exist. They should be next to wp-config.php or re-upload them (not wp-config).

    Hi,

    Check with this plugin:

    http://wordpress.org/extend/plugins/fix-rss-feed/

    Thanks,

    Shane G.

    Ok, so the plugin kind of fixed the fact that the feed couldnt be found (thanks for that shane), now I can access it BUT I still have one little problem:

    the browsers still don’t recognize that it is there, there is no “rss” logo on the address bar.

    ???

    I don’t understand what you mean.
    And this one looks allright: http://main-trainer.de/feed/

    like I was saying, the feed NOW shows up here: http://main-trainer.de/feed/ after using the fix rss plugin.

    and what I mean is, whenever you go to a page that has an rss feed, the browser automatically detects the rss feed and places a little icon like this on the adress bar, that icon is clickable and ads the feed to your reader of choice.

    rss icon

    the news page on the website I am having the problem with does not have that icon:

    rss no icon

    meaning, that the rss feed is somehow not being automatically recognized by the browsers and I am wondering why.

    I hope you know what I mean now and some one can help me.
    Thanks in advance.

    Ok, I ususally use IE7 that does not have this extra but Fireox does and it shows my own RSS logo at the righthand side of the address bar.
    Yours does not but I see now that your link goes to feedburner. Don’t know if that makes a difference (or is that a recent workaround?)

    yeah, it makes a bit of a difference because the browser isnt finding the feed automatically (neither safari, nor chrome nor firefox) and I have to manually place a link in the page so that people can subscribe to the feed, but I would like it to be there automatically if that makes any sense.

    Just noticed that there are no in coming links and my RSS feeds link doesn’t work in WP 2.91 (but seems to have been happening for a while). Feed Validator gives this message: Server returned HTTP Error 404: Not Found.

    I’m using the Day and name permalinks setting but http://www.abengnews.com/feed doesn’t work, nor does feed/rss, feed/rss2 or any suggested link option.

    This seems a pretty widespread error but no real solution.

    Hi Folks,

    Same problem here.

    Tried the rss fix plugin but no change.

    Everything else is working fine but http://beleghebamme.com/feed gives a “page not found” error.

    @twotwentysix: I was having the same problem with the RSS icons not apearing in browsers. I was advised to insert the following piece of code between my <head> and </head> tags:

    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="<?php bloginfo('rss2_url'); ?>" />
    <link rel="alternate" type="text/xml" title="RSS .92" href="<?php bloginfo('rss_url'); ?>" />
    <link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="<?php bloginfo('atom_url'); ?>" />

    This apparently alerts browsers to the fact that the feed exists. It worked right away for me, so big credit to Esmi who passed on this tip. Hope you get everything sorted out OK.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Rss Feed not working, can’t be found’ is closed to new replies.