Support » Fixing WordPress » RSS Feed not working

  • I am having trouble getting my RSS feed to work. I have disabled all my plugins and still nothing. Not really sure how to tackle this.

    And help or guidance would be great, thanks!

Viewing 15 replies - 1 through 15 (of 17 total)
    this site?

    feed gets 500 error
    what have you done to modify things?

    also, your feed icon in footer is linked to a sign up page – that would annoy the hec out of me if I was visiting



    Forum Moderator

    totally missed the feedburner but /feed should still redirect to the feedburner feed so something is still not right

    Site is working fine on my end, not sure where the error is coming from. has only grabbed content from 5 days ago, I have since updated the site many times. I am using the feedburner plugin and have been using is fine for almost a year…

    I’ll change the subscribe button to an actual feed.



    Forum Moderator

    It might help if you temporarily removed the feedburner redirect so that we can troubleshoot the actual RSS file.




    Forum Moderator

    There is absolutely no output at Have you moved the site recently. Or changed site urls?

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    I haven’t change URLs or moved the site. It went down last week due to some files that went missing, not sure how they went missing, but I had to reupload a new theme folder

    I will give this a try…

    Deactivating plugins didn’t work

    resenting the plugin folder didn’t work

    I just updated, this morning, to 3.2.1 form the previous version of wordpress. The reason I updated was because of the feed issue. I could be wrong, but doesn’t this replace the wp-admin and wp-includes folder?



    Forum Moderator

    Yes but not always successfully. And what about switching to Twenty Eleven?

    same deal in twenty twelve…

    I will upload a clean version of wp-admin and wp-includes and see if that works

    Got this from feedburner overview.

    This feed does not validate.

    Server returned HTTP Error 500: Internal Server Error [help]

    line 1, column 0: XML parsing error: <unknown>:1:0: no element found [help]

    In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendation.

    Feeds should not be served with the “text/html” media type [help]

    fresh wp-admin and wp-includes with no luck…

    Ok, I have pretty much replaced just about every file and still nothing, any ideas on a work around of some sort?

    Any ideas would be helpful thanks!

    After digging through again, it looks like I might have spaces somewhere that might be affecting the rss feed? The feed is loading in safari but not in chrome.

    The validator gives me the following errors. I have deleted my rss.php rss2.php feed.php and wp-feed.php and replaced it all with fresh and had somewhat of a breakthrough.

    If there are spaces affecting my feed I am not sure where to find the file to get rid of them.

    Any help would be much appreciated, thanks!

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘RSS Feed not working’ is closed to new replies.