WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] rss feed not working

[Resolved] rss feed not working

  • The rss feed in my blog is not working at all. I tried installing wordpress multiple times, I changed the themes, but all in vain. The firefox live bookmark won’t work on that. When I pass the feed through a validator, there is junk after document. There is some kind of analytics code after </rss>. If elimination of this code can work, how do I do that?
    My blog feed is here:
    http://www.nurvsofsteel.0fees.net/news/feed

    Someone please help.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You can safely remove all this starting at line 216

    # <div style="text-align: center;"><div style="position:relative; top:0; margin-right:auto;margin-left:auto; z-index:99999">
    #
    # <!-- Website Analytics Code -->
    # <script type="text/javascript" language="javascript">
    # var websiteID=34522;
    # var refID="d4S3sT";
    # </script>
    # <script type="text/javascript" language="javascript" src="http://analytics.hosting24.com/do.php"></script>
    # <noscript>
    # <a href="http://www.hosting24.com/" target="_blank"><img src="http://analytics.hosting24.com/do.php?websiteID=34522&amp;refID=d4S3sT&amp;from=noscript" alt="web hosting" border="0"></a>
    # </noscript>
    # <!-- End of Website Analytics Code -->
    # </div>

    Be sure and leave the last </div>

    Yeah that is the problem…
    How do I remove that?

    Website Analytics Code

    What plugin is adding this?

    I don’t know…
    afaik I’m not using any plugin
    Even if I’m doing a fresh installation (which I did thrice), I’m getting this same problem.

    Is your host adding it?
    I don’t have that on any of my blogs.

    Okay so it wasn’t the host…
    I changed the “For each article in a feed, show” in settings > Reading to summary (which was earlier full text), and that seems to have solved the problem. Now I can subscribe without any problem.

    Thanks for the help samboll.
    🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] rss feed not working’ is closed to new replies.
Skip to toolbar