Support » Fixing WordPress » RSS feed not validating

  • Hello,
    I have read everything I could find on this problem and I’m still not sure what to do. I have 2 blogs using WordPress, http://over-50-and-kicking.com and a new one http://womenscorner.com
    The first one, the RSS feed validates no problem. The second one won’t and the error I got was:
    Your feed appears to be encoded as “utf-8”, but your server is reporting “US-ASCII” [help]
    line 2, column 0: XML Parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]
    <?xml version="1.0" encoding="utf-8"?>
    Source: http://womenscorner.com/wordpress/wp-rss2.php
    <?xml version="1.0" encoding="utf-8"?>
    <!-- generator="wordpress/1.2.1" -->

    Someone said it could be whitespace in the php file…but which file? the index.php? and if so where do I look? I checked and there is no space at the beginning.
    Can anyone help me please?
    Thanks
    Lise

Viewing 15 replies - 1 through 15 (of 39 total)
  • First part:
    Add “AddDefaultCharset utf-8” to your .htaccess

    http://www.feedvalidator.org/check.cgi?url=http%3A%2F%2Fwomenscorner.com%2Fwordpress%2Fwp-rss2.php
    >line 2, column 0: XML Parsing error: <unknown>:2:0: xml declaration not at start of external entity [help]
    1.
    2. <?xml version="1.0" encoding="utf-8"?>

    For some reason you’re getting a space at the top of the output. The line above needs to be on the first line to validate.
    If nothing is wrong with the file, try turning off any plugins, to see if that’s the cause (as it was here).
    .

    Hey guys,
    Sorry I had to do something.
    OK Podz, I tried adding Adddefault…but that did not work. It still not validating. Did I have to put the ” ” ?
    And Kafkaesqui, I turned off the WP grins plug in(which is the only one activated) and it still did not rectify it.
    I’ve wasted so much time on this, it’s so frustrating.
    I really don’t know much about php so maybe there is a space somewhere I’m not seeing.
    Podz, you helped me before….if I give you access could you try to see what’s wrong? I hate to bother you but I’m at my wits end.
    Please 🙂
    Thanks
    lise

    Moderator James Huff

    (@macmanx)


    Try replacing wp-rss2.php with a new copy from the download.

    macmanx,
    Thanks…I tried and it’s still not validating….I’m pulling my hair 🙁
    Can someone try it in their RSS feeder and see if it works anyway?
    If <?xml version="1.0" encoding="utf-8"?> has to be on the 1st line, I don’t know how to do that. Can someone tell me please?
    Thanks
    Lise

    Hey Kafkaesqui,
    that’s a neat place that paste.uni – ok I did it and here is the link http://paste.uni.cc/6348
    Thanks a bunch
    Lise

    Beats me LOL – This is really foreign language to me. The only difference between my 2 blogs is:
    the one validating is the version before, does not have a form on it, and does not have a navbar at the top.
    the one not validating is the newer version, does have a form and a navbar.
    Grrrrr

    OK I’m starting to get that 🙂 So which php files should I compare maybe with the blog that works?
    wp-rss2.php, plugins.php and what other php pages should I check?

    Sorry I posted before I saw yours.
    Why is there a server config issue? you lost me LOL

    Did it and there is no extra line see http://womenscorner.com/wordpress/test.html

    I also checked on my other blog and there is no extra line either, so now we know that’s it’s either WordPress or PHP.

    Ok I did just did another page and called it test.php and upload it and view source and it’s ok no space at top

    So now we know it’s WordPress that is playing around here. Can anyone else pipe up with an idea why it’s doing this? If not, I’ll do some digging.

    Also I tried to validate the commentsrss2.php and it doesn’t either. Does that help?

    Only in that it continues to show WP is sticking that extra line at the top absolutely everywhere.

Viewing 15 replies - 1 through 15 (of 39 total)
  • The topic ‘RSS feed not validating’ is closed to new replies.