RSS feed not updating (6 posts)

  1. jb84
    Posted 6 years ago #

    For some reason my RSS feed doesn't seem to be updating anymore.

    My blog: http://php-programming-tutorial.com/blog/

    My RSS feed: http://feeds.feedburner.com/php-programming-tutorial

    As you can see, my blog has two recent posts that aren't showing in my RSS feed. I haven't changed any of my plugins. I use Feedburner, the Feedsmith plugin, and the default WordPress ping-o-matic.

    Any ideas? Thanks.


  2. Shane G
    Posted 6 years ago #


    Check with these options:

    -> Upgrade your wordpress to the latest version
    -> disable all the plugins and enable it one by one to find out the culprit.
    -> Remove all unwanted code from htaccess.


    Shane G.

  3. jb84
    Posted 6 years ago #

    Thanks. I am using the latest version of WordPress.

    I think I found the problem. As soon as I disable the Feedsmith plugin, it works fine. So for some reason Feedsmith is blocking my recent posts.

    If anyone has my problem, try disabling Feedsmith. I wonder why it's doing this.

    Thanks again. :)

  4. jb84
    Posted 6 years ago #

    Interestingly, Feedsmith's site gives a 404 as of now: http://www.feedburner.com/fb/a/help/wordpress_quickstart

  5. rwalling
    Posted 6 years ago #

    Thanks for this thread - I'm seeing the same issue after upgrading from 2.8.1 to 2.8.4.

    My feed has been functioning with no problems for a few years through WP and FeedBurner. But a couple weeks ago I upgraded to WP 2.8.4 (from 2.8.1) and now although I have two new posts on my home page (http://www.softwarebyrob.com) they are not appearing in my feed (http://feeds.feedburner.com/SoftwareByRob).

    I have re-synched the feed, I have disabled the FeedSmith plugin, and I have disabled all of my plugins but nothing has any effect. Note: since then I have re-enabled them.

    I'm also confused by the fact that this URL should be my RSS feed source: http://www.softwarebyrob.com/rss2, but even when I disable the FeedSmith plugin, when I hit http://www.softwarebyrob.com/rss2 it still takes me to FeedBurner. I can't figure out any way to keep FeedBurner from redirecting my feed (I've even gone and looked in .htaccess and there's nothing fishy in there).

    At this point, after 3 hours of troubleshooting, I am throwing up my hands. Any help is greatly appreciated.

    BTW - I just upgraded to WP 2.8.5 a few minutes ago and that doesn't help. I also confirmed I have the latest version of the FeedSmith plugin.

  6. rwalling
    Posted 6 years ago #

    Wow, finally fixed it. I went into FeedBurner and changed the "source" URL for my feed from:




    And everything works now.

    My best guess is that the /rss2 format has been deprecated. Things that would have been good to know 5 hours ago when I started troubleshooting.

Topic Closed

This topic has been closed to new replies.

About this Topic