[resolved] RSS Feed Not Updating (7 posts)

  1. aldrichb
    Posted 3 years ago #

    I posted something this morning on my Podcast RSS feed. Usually I am able to refresh the feed on my podcast player (Downcast for iPhone) and I can instantly download the latest episode.

    After posting, I can't seem to download it. I go to the "Validate Feed" button in the Podpress options and it doesn't show the latest post. But I do see the post on my main RSS feed and site.


    Any ideas?

    Thanks in advance,


  2. aldrichb
    Posted 3 years ago #

    Follow up

    I checked the feed http://www.seacoastbeveragelab.com/?feed=podcast and it looks fine and downloads on my app. I saved and re-saved the permalink settings every which way, is there any way to push the post to the /feed/podcast feed?

    Is there any reason not to change my feed in itunes to http://www.seacoastbeveragelab.com/?feed=podcast instead?

  3. ntm
    Plugin Author

    Posted 3 years ago #

    Hi Brian,

    are basically the same. The first URL is only a variation of the second URL. Both lead to the same content.
    I do not know why the validator showed you an incomplete feed. But if you try that again today, it will show you the last post too.
    One reason this glitch maybe your Cache plugin which may have delayed the delivery of the last post via the feed. But I'm not sure of that.


  4. aldrichb
    Posted 3 years ago #

    Thanks Tim

    I'm still not able to see my newest episode in my app or in iTunes. How can I properly update my iTunes feed too look at that other address instead of the one that is acting a little funky?

    Thanks again

  5. ntm
    Plugin Author

    Posted 3 years ago #

    That 's strange. I opened both URLs again and now I can see what you tell me. Earlier the behaviour has been different and I could see episode 14 after opening both URLs.

    This behaviour is most likely related to the WP Super Cache plugin which you use.

    In the source code of the /?feed=podcast version I can read this comment:

    <!-- Dynamic page generated in 1.049 seconds. -->
    <!-- File not cached! Super Cache Couldn't write to: wp-content/cache/wp-cache-e92e0fb1e440fbff823b84c41e8335fc.html -->

    in the source code which I get after opening the /feed/podcast URL the comment of the plugin is the following:

    <!-- Dynamic page generated in 1.645 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2012-11-14 15:35:12 -->

    It seems to me that Cache plugin has trouble handling the /?feed=podcast feed URL and can not cache the content. That is why you can see the episode 14. If you open the other URL the Cache plugin shows one a version of the feed which is still in the cache memory stored.
    I'm not sure why this problem occurs. But I guess you should try clear the cache memory of the plugin in order to update the feed and the iTunes Store page. (Please note that the iTunes page updates only once every 24 hours.)

    (I'm going to add wp-super-cache as a tag to this thread.)

  6. aldrichb
    Posted 3 years ago #

    I think you hit the nail on the head. When I go into WP SuperCache i see

    "Error: Your cache directory [directory] or [directory] need to be writable for this plugin to work. Double-check it.
    Cannot continue... fix previous problems and retry."

    Ill look into that now.

  7. aldrichb
    Posted 3 years ago #


    Worked like a charm, thanks for the deep diving help! Great plugin!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic