Support » Fixing WordPress » RSS Feed Not Including Latest Blog

  • Hey guys,

    I’m seeking help. I’m trying to use my WordPress RSS feed to send automated emails, via MailChimp, when a new blog post is published.

    Unfortunately, when I check https://validator.w3.org/feed/ my latest blog post is not included in the the RSS feed. That said, when I check, my latest post is at the top of the feed. Nevertheless, my automated emails refuse to send, and my my test emails only pull information from the previous blog post, published in October.

    For reference, I’m using the WP Super Cache plugin, and I’ve heard that could be causing issues. That said, deactivating the plugin did not immediately solve the problem. I’ve tried contacting MailChimp, but little was accomplished. Instead, they argued that I should wait 12 hours to see if the RSS feed updated to include the new post.

    Any help is appreciated.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • I checked the feed you say you need help with. It contains the referenced blog post.

    It takes a bit of time to generate a fresh RSS feed but it’s not that long normally.

    I would expect the RSS to MailChimp mechanism to work once the item shows up in the RSS feed and the feed is polled by MailChimp. Of course, MailChimp needs to work and be configured properly. You’ll need to discuss any MailChimp issues with them.

    As to the validator results… they might cache the last feed so if they had cause to retrieve the feed earlier they’ll probably work off that cached feed until the expiry is reached.

    I figured it out. I had to add a line of PHP to refresh the RSS feed ever 60 seconds, versus WordPress’s 12 hour standard.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.