Support » Installing WordPress » RSS Feed no longer working

  • Hi,

    I’ve had this problem for around two weeks and I can’t fix it. My RSS is no longer working, it says that it is missing a blank space and then it displays the following message:

    xmlns:creativeCommons=”” xmlns:media=””xmlns:itunes=””

    I searched on the web and I wrote a nickname for my profile and a reloaded all the files that have to do with either RSS or Feed without success.

    Can anybody help me?
    My website is at:

Viewing 8 replies - 1 through 8 (of 8 total)
  • theapparatus



    A link to the rss in question would be helpful.

    Thanks for checking my question, here is the link

    My RSS Feed

    Happy New Year & thanks to all the WP volunteers.


    I recently upgraded from WP 1.5 to 2.3.1.

    Ever since, I’ve been having problems with my RSS 2.00 feed

    which will not validate and this is the response I’m getting:



    This feed does not validate.


    line 1, column 0: Undefined root element: br [help]


    line 2, column 0: XML parsing error: <unknown>:2:0: junk after document element [help]

    <b>Warning</b>: load_template(/homepages/37/d94648496/htdocs/vassan/wp-incl …

    In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendation.


    Feeds should not be served with the “text/html” media type [help]


    2. <b>Warning</b>: load_template(/homepages/37/d94648496/htdocs/vassan/wp-includes/feed-rss2.php) [function.load-template]: failed to open stream: No such file or directory in <b>/homepages/37/d94648496/htdocs/vassan/wp-includes/theme.php</b> on line <b>440</b>
    4. <b>Fatal error</b>: load_template() [function.require]: Failed opening required ‘/homepages/37/d94648496/htdocs/vassan/wp-includes/feed-rss2.php’ (include_path=’.:/usr/local/lib/php’) in <b>/homepages/37/d94648496/htdocs/vassan/wp-includes/theme.php</b> on line <b>440</b>



    when I enter


    @ the W3C Feed validator service these two do validate!

    Appreciate any help that will enable me to correct the RSS 2. Feeds.

    I tried to look for files that may be missing @ wp-includes by comparing wp 1.5 to WP 2.3, but it was a bit beyond my limits.

    Thanks again.

    You can’t validate a feed that doesn’t exist–hence the errors. When I click your RSS2 link, I see PHP errors–the feed doesn’t exist.

    Looks like when you upgraded, one of the necessary files somehow got missed. Try uploading wp-includes/feed-rss2.php again.

    May also want to check that each directory on your server has the right number of files in it (just in case other files also got dropped).

    I’m not sure – as the WP thing is new to me, but it seems I’m having a similar issue – when I click the subscribe button – I get a PCBD error.

    the URL for the Feed/Subscription is – feed:

    This one is working ad takes you right to the XML page:

    Why is the Subscribe button link adding the FEED in front of the http:…..portion, and which PHP page can I find this code in to change the behavior?



    srasay2, this is unrelated to the thread–it should have been a new thread.

    Anyway, it’s like that because whoever wrote your theme wants to bug you. (Somebody’s going to jump on me for saying that, I expect.)

    Anyway, open up your theme, open footer.php, and you should find it. Everytime you see something like this:

    <a href="feed:<?php bloginfo(.......

    Get rid of the feed: part. It’s in there two or three times.

    Thanks – I’ll take a look – and as for the thread – I didnt want to start another thread if it was related – I know how much people love to see the same thing over and over on forums…

    Thanks again!


    Thanks a lot Adam Brown. I reloaded the feed-Rss2.php file & it seems to have solved my blog’s problem.

    But the ” feed validator ” still doesn’t give the feed a 100% clearance, so to speak 😉

    pl.have a look..



    This is a valid RSS feed.


    This feed is valid, but interoperability with the widest range of feed readers could be improved by implementing the following recommendations.

    line 58, column 1: Missing atom:link with rel=”self” [help]

    </channel> ^Source:
    <?xml version=”1.0″ encoding=”utf-8″?>
    <!– generator=”wordpress/2.3.1″ –>
    <rss version=”2.0″

    <title>அமேரிக்காவில் தமிழன்</title>
    <description>காவிரிக்கரையில் பிறந்து ரியோ க்ரேண்ட் கரை ஒதுங்கியவன்</description>
    <pubDate>Thu, 03 Jan 2008 00:46:53 +0000</pubDate>
    <title>வணக்கம் 2008</title>
    <pubDate>Tue, 01 Jan 2008 04:12:12 +0000</pubDate>







    <guid isPermaLink=”false”></guid&gt;
    <description><![CDATA[<p>எல்லோரும் எப்போதும் சொல்கிறது போல, மற்றொரு ஆண்டு முடியப் போகிறது. போகிற ஆண்டு கற்பித்ததை ஞாபகத்தில் வைத்து, இந்த வருடம் மேலும் நிம்மதியுடன் அனைவருக்கும் அமைய வேண்டும். இப்படி சொன்னால், நினைத்தால் மட்டும் போதாது. ஆவன செய்ய வேண்டும்.</p>

    <p>சொந்த தொழில் செய்யும் போது ஏற்படும் இக்கட்டுகளை, சரிவுகளை நேரிடையாக எதிர்கொள்ளும் போது, ‘பட்டறிவு, தந்தையின் மேம்பட்ட பட்டறிவு, மனைவியின் தோழமை’ என்பன போன்றன எமக்கு பெரிதும் உதவி வந்துள்ளன. இவற்றையும் மீறி நூலொன்றைப் படித்து இன்னற் களைய […]</p>
    <title>நன்றிக்கு நன்றிகள்</title>
    <pubDate>Thu, 22 Nov 2007 23:56:29 +0000</pubDate>



    <guid isPermaLink=”false”></guid&gt;


    I tried in vain looking for the right file where the < channel > & < / channel > is located but couldn’t figure out. Also, I wasn’t sure if I’m allowed to add the missing atom link manually ( this assuming I understand the f.validator advise correctly)


    Thanks again.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘RSS Feed no longer working’ is closed to new replies.