WordPress.org

Support

Support » How-To and Troubleshooting » RSS Feed is invalid, how to fix?

RSS Feed is invalid, how to fix?

Viewing 3 replies - 1 through 3 (of 3 total)
  • esmi

    @esmi

    Forum Moderator

    You have leading blank spaces at the beginning of the RSS file which is invalidating your feed. Try:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    I have tried all four of those options now.

    • After deactivating all of my plugins, the issue was still there.
    • Switching to Twenty Eleven, again, didn’t resolve the problem.
    • Resetting the plugins folder by FTP and PHPMyAdmin (alternately, not simultaneously), didn’t resolve the issue.

    I have an identical site on my local testing server, with almost all of the plugins on my remote site active (plugins such as IntenseDebate and Jetpack are not running locally as they require the plugins in the wild), and the feed works as desired. Could it be a problem with the WordPress software and the feed generation script? I have the AddToAny plugin installed and the feed option does not work, but importing the feed into Google Reader seems to return the valid posts. Feedburner (owned by Google) also returns that it is an invalid feed with the same issue.

    esmi

    @esmi

    Forum Moderator

    Could it be a problem with the WordPress software and the feed generation script?

    Sorry, no. This problem is specific to your site. Can we see your site using Twenty Eleven with no plugins active?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘RSS Feed is invalid, how to fix?’ is closed to new replies.