WordPress.org

Support

Support » Alpha/Beta » RSS feed has wrong format

RSS feed has wrong format

  • When generating feed foor podcast the generated feed is invalid. It contains first a blank line and than the rest of it. When I save it in plain xml file and remove the first blanc line feed is OK. What kan I do?
    I’ve installed it on my Yahoo business webhost. Wordpres is <!– generator=”wordpress/2.0-RC2″ –>

    Please help

Viewing 13 replies - 1 through 13 (of 13 total)
  • This is not a problem with the beta. See this thread (among many) for possible ways to track down and fix:

    http://wordpress.org/support/topic/40580

    I’m a troglodyte. someone is helping me set up a podcast.

    When we put the following url into my blog it shows up fine and I can click to download the audio. But feed validator cannot find it. Do we need to convert something? Somehow???

    This pops up as a link so please right click on the properties to see the html

    Rich Audio Test #!

    and i submit rss feed to feedburner.com, it reports “Unexpected end of file from server”.
    help too.
    wordpress 2.0-RC3

    feedvalidator.org reports OK.

    raenoll,

    Are you saying you submitted YOUR feed or my feed to feedburner??? I dont’ get it.

    Is the “Unexpected end of file from server”. about my rudeguy feed, or your feed????

    What should I cut out???

    And what is wordpress 2.0-RC3 referring to???

    i was submitting my rss feed generated by wordpress 2.0 rc3 to feedburner.com and it failed. feedburner shows “Unexpected end of file from server” about the submitting but feedvalidator.org shows the original rss feed which i want to submit to is Valid.
    so that’s the problem.

    OK, I understand now. I hope someone hops on both of our problems. Anybody out there?

    Moderator James Huff

    @macmanx

    Have you tried de-activating all of your active plugins?

    Thank you macmanx,
    I will pass that along to the person who is setting up the blog. At last we have soemthing to try to solve the problem. I never downloaded any plug-ins but perhaps she did.

    macmanx,

    Nope. NO plug-ins running on the site. I’m baffled. The person helping me is running Win XP and I am running WIN 98. I thought that might be a problem but she says it shouldn’t be. We are both using WordPress 1.5.2 as provided by the bluehost site.

    Anybody out there?

    One of my feeds worked. Can’t figure out why.
    But I wonder if the problem is something to do with word press themes. I used red train for the blog, but I see my “helper” has started a page called Rude Guy 1. When I open that theme I get a blue banner across the top (different page) but all my posts are there. I wonder if there is some confusion between the theme pages. Does anyone know about that?

    Also, if I click on “you” after “my” theme page I get some binary something web page. Goofy.

    I did put the successful feed through feed burner. One worked one didn’t apparently. I’m lost.

    Moderator James Huff

    @macmanx

    The blank line is typically caused by either a blank line at the top or bottom of a plugin file or a core WordPress file. Since there were no plugins running at the blog, then that would obviously not be the problem, so check all of your core WordPress files. The best way to do this would simply be to download a new copy of WordPress, delete all of the existing core files and upload new copies from the fresh download of WordPress. If the problem continues, then you must individually check each file.

    Resolved.

    Unix could not process a “#” that I had in the title of my audio post.

    thanks,

    The Rude Guy

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘RSS feed has wrong format’ is closed to new replies.