Support » Fixing WordPress » RSS feed from blog not working

  • I look after a blog for a friend the url is

    annamaymangan is a wordpress self hosted site.

    She is linked to from another blogspot blog,
    however this link doesn’t work properly. It appears to use the Blog
    List widget, and the snippet appears correctly, but the url on the
    link is back to womanwhotalkedtoomuch and not annamaymangan

    I’ve replicated this on and get
    exactly the same effect. The snippets appear
    correctly, but the urllink is back to yours2share and not

    All other links back to from other
    websites appear to be OK, including those from another blogspot blog.

    I’ve looked through WordPress documentation and can’t see what I need to do. I’ve been through all the settings and can’t see anything that looks even remotely to do with RSS. Stumped. Can’t say I really understand RSS. Also can’t understand why this did work until a month ago and now it doesn’t. It stopped working after an upgrade from 2.7.0 to 2.7.1

    Digging around, the problem appears to be related to the RSS feeds which the blogspot blog list works from. If I set up the RSS widget (standard WP) I get an error in the widget set-up “Error: could not find an RSS or ATOM feed at that URL.”

    There are other people looking for solutions to similar problems, some suggest it might be a hosting issue, but I have two other wordpress blogs with the same hosting company on the same server, so that doesn’t make sense.

    I’ve tried altering the permalinks and deactivating all the plugins, to no avail.

    Any ideas, please?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Moderator kmessinger


    The feed for the whttm is here,

    The link in anna…mangan to whttm is different than the other links – at least a different color – maybe that means something.

    I get an error in the widget set-up “Error: could not find an RSS or ATOM feed at that URL

    The widget installs with this message. You need to replace it with the feed address.

    Thanks for your quick reply, but I really don’t understand it.

    Why do I need the feed to whttm?

    Where is the link with a different colour?

    What feed address do I need to put into the widget, and why have I not needed to do this before?

    Moderator kmessinger


    Why do I need the feed to whttm?

    You don’t. I misunderstood.

    Where is the link with a different colour?

    The link that is the problem, on whttm is a different color than other blogroll links on that site – so I would suspect something is different.

    What feed address do I need to put into the widget, and why have I not needed to do this before?

    1.The address you want feed from. 2.I don’t know. Everytime I have installed it, it installs with that error message. I delete that message and put the feed address I want to appear on the sidebar.

    You are concerned about a link from another site to you that is incorrect. Your feed does not validate. See,

    Your site has a few errors that might contribute to the problem. See,

    Many thanks again

    The key issue for me is that the feed does not validate, so it cannot be picked up by another website.

    I’ve removed most of the errors that came up with the validation check and think the only way to remove the last validation two errors is to move to a different theme. I’ve tried using a standard WP theme and the validation has no errors, but still the feed validation is incorrect. It is consistently not picking up the main url.

    Is this something that needs a few minutes or hours to sort itself out, or if it is correct should the feed validate immediately?

    If the latter, then problem would appear not to be the theme.

    Moderator kmessinger


    Try this validator for correcting the feed,

    The feed problem on the other site will not correct until that site calls for feed again. Some take hours.

    I’ve still not managed to get this sorted. I’ve rebuilt the site, importing the old data into a new database and reloading all the files. I’ve changed the theme and now get no validation errors for the pages, but the feed still won’t validate.

    I then switched the new installation to look at a blank WP new database and the rss feed works fine. However I need to keep the existing data, I don’t want to ust abandon it.

    So somewhere in the data is the problem, but where? There is a table called options looks the most likely and many of the option_names start with rss, but I don’t know what any of them mean. I’ve been through all the admin settings and set and reset many of them to see if I can make any difference, but no luck.

    All ideas gratefully received.

    I’ve finally sorted this out. I compared the options tables in my installation against vanilla. I realised that one of the differences was that the option_name of “Home” on my installation was just http:// and should the home url.

    I edited this directly in the database.

    Everything then works fine.

    This also puts the full url into the Setting/General/Blog address (URL), which I would have thought should be blank. Even so I’d tried putting the full url in several times, to see if this made any difference. However I probably did this with a previous theme and I think the source of my problems has been that this theme couldn’t cope with the upgrade to 2.7.1

    Moderator kmessinger


    Great! Glad all is working. You might want to mark this one resolved.



    Can anyone please tell me how to repair my feed?

    My WordPress blog is Gotham Glassworks by Greg Locke

    Since I upgraded to 2.9 my RSS feed has been corrupted and for the life of me I can’t figure out why (even after reviewing the forums, like this one, on this topic). My symptoms seem to be similar to others in the forums but obviously not in my case.

    In addition, My XML sitemap generator plugin only seems to complete a new sitemap if I force it to do so “manually”. The sitemap appears OK when I view it – but I can’t explain this – my posts do not come up in any very obvious Google searches – only my Flickr, Youtube or 3rd party results show.

    From what I can determine, using an online RSS validator I seem to have 2 pieces of code that is halting the feed from being generated. I can see the code in the RSS verification BUT … as I’m not a programming expert I can’t figure out how (or where) the code is being generated.

    Strangely there doesn’t seem to be anyone else complaining of this problem since the 2.9 upgrade.

    Here is what I see when I check the Original Feed Validity:


    It looks like this is a web page, not a feed. I looked for a feed associated with this page, but couldn’t find one. Please enter the address of your feed to validate.


    <title>404 Not Found</title>
    <h1>Not Found</h1>
    <p>The requested URL /feed/ was not found on this server.</p>
    <p>Additionally, a 404 Not Found
    error was encountered while trying to use an ErrorDocument to handle the request.</p>
    <address>Apache Server at feed Port 80</address>

    Here is what I see when I check the Feedburner Feed Validity:


    This feed does not validate.

    line 830, column 1: length attribute of enclosure must be a positive integer (2 occurrences) [help]

    <enclosure url=’ …
    line 1140, column 6: XML parsing error: <unknown>:1140:6: junk after document element [help]

    </rss><adsttnmq1><font style=”position: absolute;overflow: hidden;height: 0; …
    In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendation.


    Line 1140 seems to be the most offensive but I have no idea what can be generating this code! It doesn’t appear in any of my posts or pages (I’ve bolded it below and it appears at the very end of the “feed”):

    </rss><adsttnmq1><font style=”position: absolute;overflow: hidden;height: 0;width: 0″>dfkj31sk342</font></body></html><sdioyslkjs2>
    <!– Dynamic Page Served (once) in 1.665 seconds –>

    line 13, column 93: Self reference doesn’t match document location [help]

    … rel=”self” type=”application/rss+xml” />

    Can anyone give me a tip n how to diagnose an remove this code? This assumes this will even fix it!

    Happy New Year to you all from Canada.


    Greg Locke



    Hello again,

    I think I should have created a new post with my problem above – so I did!

    Please come here and sorry for any confusion.


Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘RSS feed from blog not working’ is closed to new replies.