WordPress.org

Support

Support » How-To and Troubleshooting » RSS feed error.

RSS feed error.

  • I’m getting the following error when attempting to open the RSS feed to my site:
    XML Parsing Error: xml processing instruction not at start of external entity
    Location: http://www.3mote.com/wp-rss.php
    Line Number 3, Column 1:<?xml version=”1.0″?><!– generator=”wordpress/1.0.1″ –>
    ^
    any ideas?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Yes, I did notice that it started working after a little while…Thanks, I’ll fix up the code.

    Is this what’s supposed to appear in the wp-rss and wp-rss2 files?
    <?php echo “<?xml version=\”1.0\”?”.”>”; ?>
    <!– generator=”wordpress/<?php echo $wp_version ?>” –>
    Thanks.
    Ben

    Does anyone else get this error when they open the wp-rss2.php file? I’m using the standard file that came with the installation.

    Do you have PHP auto-prepending something? You’re getting an XML/HTML comment surrounding a PHP comment saying “Author link to posts hack” as the first line of wp-rss.php’s output, and in XML you can’t have anything, not even a blank line or a space, before the <?xml … line. So wherever that “Author link to posts hack” line is coming from, it needs to go away.

    I would double-check your my-hacks file and make sure there’s nothing outside the <php ?> tags.

    ahhh, yes, I guess I can’t comment the my-hacks file. That was it. Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘RSS feed error.’ is closed to new replies.
Skip to toolbar