Support » Fixing WordPress » RSS Feed error

  • Resolved Bird is the Worm


    I’m getting the following feed error on my site ( It is my own site. I am self-hosting WordPress. I use Contempt as my theme. I’m up to date on my WP updates.

    Error message=

    XML Parsing Error: XML or text declaration not at start of entity
    Line Number 3, Column 1:<?xml version=”1.0″ encoding=”UTF-8″?>

    Having spent half a day searching the internet, I am clearly not the only one who has encountered this problem. But I am struggling to get started on solving this problem. My analogy is that I recognize the ingredients, I can picture what the finished meal will look like, but I can’t seem to find the pantry/kitchen to get started. Does that make sense? No matter how many times I read and re-read the threads on this forum and other sites, there has to be something essential that I’m overlooking or not understanding, because it seems like other people are resolving the same problem.

    When I go into my Editor, I can’t find any rss language anywhere. Based on what I read and what I can see on my site, I’m thinking I might have a blank line where there shouldn’t be one. But I’ve gone through all my menus in the Editor, and I can’t find any RSS language anywhere. Nor can I find the above lines about XML versions and UTF encoding. That seems problematic to me.

    I am very new to this, and it got me to wondering if I even had the correct RSS functionality activated on my site. I was under the impression that it got installed as part of my Jetpack plugin. When I installed Jetpack, it did create a RSS link on my META menu (right hand side of site page, all the way at the bottom). Also, when I enter my RSS feed URL into a validation site, it comes back as being a valid feed. Also, I used the fix-rss-feed plugin and the check-rss-feed-status plugin, and they both seem to think everything is working fine. But it’s not.

    I think the help that I would like to receive is a pointer on where to find the RSS feed code language in my editor so I can go about trying to fix the problem. Or, if my understanding of how all this works is incorrect to begin with, then a pointer on where I’m misunderstanding things.

    My most constructive learning with html and coding, etc, has been in researching and solving my own problems, so I try to embrace these problems with optimism. But this RSS thing has got me spinning in circles.

    Any help would be appreciated.

Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi


    Forum Moderator

    I’m not seeing any issues in your RSS feed at the moment.


    I followed a hunch and tried it on Safari. It works fine.

    However, on Firefox, it’s not working at all.

    And that reminds me, on the rss-fix plugin, it does mention something about a Firefox issue. Hold on, let me look that up and link to it.

    Okay, here’s the description for the plug-in fix-rss-feed…

    Fix wordpress rss feed error “Error on line 2: The processing instruction target matching “[xX][mM][lL]” is not allowed.” while you burn wordpress rss feed from, also fix error “XML or text declaration not at start of entity” in firefox, and fix error “XML declaration not at beginning of document” in opera.

    I am getting that “XML or text declaration” error in Firefox (my standard browser).

    However, the plug-in didn’t actually fix that problem (which may be valid, because the details state that it hasn’t been tested on WP 3.3.2).



    Forum Moderator

    I checked your feed using Firefox 11. No problem.
    The Feed validator says its a valid feed, too.

    While I certainly love hearing people tell me there’s no problem with my site, I’m confused why I and one other person are not able to get the feed to work and instead get the above error message.

    I checked my Firefox, and it’s also version 11.

    Huh, I’m flummoxed.

    P.S. Got the same result as you on the validator.

    P.S. Esmi, my sincere thanks for your help.



    Forum Moderator

    Remember to press CTRL and F5 simultaneously when viewing an updated page/site. Or try emptying your browser cache. This should ensure that your web browser fetches a fresh copy of the page rather than serving up an out-dated copy from your own cache.

    Also disable/deactivate any caching plugin(s).

    Okay, I’ve got a message out to a few people to test it.

    Out of curiosity, is there somewhere in my site Editor that I can access the RSS code? I still don’t know where to find it.




    Forum Moderator

    No – you cannot access your RSS feed file. It is generated on demand by WordPress.

    So, then the blank lines that many sites recommended deleting (before and after php files), that’s basically just something to go through the Editor line by line all the various menu options?



    Forum Moderator

    One common cause of leading blank lines in an RSS feed is leading blank lines in other theme template files – such as header.php. Perhaps that is what you’ve been reading about?

    Yes, the header.php gets mentioned the most, and it was where I was mistakenly assuming I’d see some RSS language.

    I think I’ll take a second pass at looking for blank lines in the header php now. I was pretty sure I picked through it pretty good, but I think when anybody isn’t entirely certain that they’re doing the right thing, mistakes can be made and things get overlooked.

    I’ll try again.


    Okay, it works again. I haven’t heard back from the person who originally reported the error, but I was able to reproduce his error message before and now I can’t. I think maybe a couple of the things I modified before (ie, the fix-rss-feed and deleting some blank lines) may have actually fixed it, but I just needed to wait a bit longer for the server to reset.

    Now that I think back on it, there have been other “bigger” changes I’ve made to the site and just wasn’t aware of the time interval before those changes were reflected in real time. That may account for the delay in this instance too.

    Thanks again for your help. It’s always comforting to know that helpful people are out there looking out.


    P.S. Please feel free to hang one of those “Problem Resolved” signs on this thread.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘RSS Feed error’ is closed to new replies.