WordPress.org

Support

Support » Themes and Templates » [Resolved] RSS Feed Error

[Resolved] RSS Feed Error

  • Having some issues with the RSS feed link. When I subscribe via Google Reader, everything works just fine, otherwise, I receive the following errors…

    When I attempt to resolve it via the web browser:
    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://www.seattlecoffeegear.dreamhosters.com/blog/feed/
    Line Number 3, Column 1:<?xml version=”1.0″ encoding=”UTF-8″?>
    ^
    When I attempt to swap it out for the older source URL for my Feedburner account:
    The URL does not appear to reference a valid XML file. We encountered the following problem: Error on line 3: The processing instruction target matching “[xX][mM][lL]” is not allowed.

    I’m not incredibly familiar with XML; I have poked around the .php files that reference this icon/URL, but can’t seem to find out how I can fix this. Anyone have any ideas on how I can resolve?

    Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Cathy Tibbles

    @multitalentedmommy

    I saw the error too, do you have permalinks set up? the feed is written in the header as:
    mydomain.com/blog/feed/
    that will work for custom permalinks. Why don’t you go into the header of your theme templates, and change that link-rel: rss+xml to:
    <?php bloginfo('rss_url');?>

    Thanks for the response!

    Yes, I have permalinks setup. After I put your suggestion in place, it changed the error:

    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://www.seattlecoffeegear.dreamhosters.com/blog/feed/rss/
    Line Number 3, Column 1:<?xml version=”1.0″ encoding=”UTF-8″?><!– generator=”WordPress/2.7.1″ –>
    ^

    Any ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] RSS Feed Error’ is closed to new replies.
Skip to toolbar