RSS feed error. (7 posts)

  1. benrad
    Posted 11 years ago #

    I'm getting the following error when attempting to open the RSS feed to my site:
    XML Parsing Error: xml processing instruction not at start of external entity
    Location: http://www.3mote.com/wp-rss.php
    Line Number 3, Column 1:<?xml version="1.0"?><!-- generator="wordpress/1.0.1" -->
    any ideas?

  2. benrad
    Posted 11 years ago #

    Yes, I did notice that it started working after a little while...Thanks, I'll fix up the code.

  3. benrad
    Posted 11 years ago #

    Is this what's supposed to appear in the wp-rss and wp-rss2 files?
    <?php echo "<?xml version=\"1.0\"?".">"; ?>
    <!-- generator="wordpress/<?php echo $wp_version ?>" -->

  4. benrad
    Posted 11 years ago #

    Does anyone else get this error when they open the wp-rss2.php file? I'm using the standard file that came with the installation.

  5. philor
    Posted 11 years ago #

    Do you have PHP auto-prepending something? You're getting an XML/HTML comment surrounding a PHP comment saying "Author link to posts hack" as the first line of wp-rss.php's output, and in XML you can't have anything, not even a blank line or a space, before the <?xml ... line. So wherever that "Author link to posts hack" line is coming from, it needs to go away.

  6. Matt Mullenweg
    Posted 11 years ago #

    I would double-check your my-hacks file and make sure there's nothing outside the <php ?> tags.

  7. benrad
    Posted 11 years ago #

    ahhh, yes, I guess I can't comment the my-hacks file. That was it. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.