• Hi !

    Is seems that the rss feed of one of my website is not updating since almost a month ago (since about 24 janvier).

    I discovered it because my mailchimp newsletter (with rss feed automotion) was not published although several posts were pushed online.

    Same thing with brevo newsletter. Same thing with gutenberg rss block.

    The last post which appears is from 24th of january.

    I tried several things to resolve the bug. I changed my child theme and parent theme to another plain theme (2024). Tried to disable all plugins. Change the time between each cron update of rss feed in function php file…

    Nothing helped. I also verify if there wasn’t any tags or blank spaces in this file function.php…

    I disabled wp rocket cache : the bug is still here…

    My host is o2switch, php version 8.1.. I use blocksy pro with a child theme.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    If I load your feed from https://yesweblog.fr/feed/?no-cache I see everything, so that would suggest the issue is a caching system somewhere.

    Keep in mind that deactivating a caching plugin may not disable the cache. In fact, it might leave your site (or parts of your site) frozen in a cached state. Each caching plugin has different uninstall instructions and those are the only true way to disable the cache.

    If WP Rocket is still deactivated, I recommend switching it back on. Next, look for a “Clear/Purge Cache” button in your Dashboard or admin bar and try clearing the cache.

    If the problem is resolved by clearing the cache now, but returns later, I recommend contacting the support for your caching plugin.

    Thread Starter griselidis

    (@webmaster9280)

    Hi @macmanx / Jeff 🙂

    Thanks for your reply !

    When i disabled wp rocket, it was a total desinstallation of the plugin. Nothing changed with the rss feed. When i enabled it after reinstallation, i imported the previous settings.

    A priori, the rss feed isn’t cached.

    Now, wp rocket is enabled and the problem remains. I really do not understand where the bug comes from.

    I am not a beginner with WordPress, i checked the cron tasks, deleted old useless tables in the database, disabled big plugins i had like wordfence…

    I still search but do not find the source of this bug.

    Thread Starter griselidis

    (@webmaster9280)

    Forgot to mention that i also made a rollback to previous version of wp rocket and tested rss with newsletter and so on but i came back to last version because bug was here with both versions.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    When i disabled wp rocket, it was a total desinstallation of the plugin. Nothing changed with the rss feed.

    Some caching plugins add a cache directory to your server and a .htaccess rule to refer to that. In those cases, deactivating and deleting the plugin doesn’t remove the cache or the reference to is, and that’s how your site (or part of it) can stay “frozen” in its cached state.

    I don’t know the specific on WP Rocket, but consult their documentation or support for the right way to uninstall it to be sure.

    A priori, the rss feed isn’t cached.

    Something is caching it, otherwise https://yesweblog.fr/feed/ and https://yesweblog.fr/feed/?no-cache wouldn’t return two different sets of posts.

    Does your hosting provider offer server-side caching, or are you using a caching reverse proxy like Cloudflare? If not, then I recommend reaching out to WP Rocket’s support: https://wp-rocket.me/support/

    If you are also using a server-side cache or a caching reverse proxy like Cloudflare, I recommend only ever using 1 cache, because weird things like this can happen.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.