[resolved] RSS Feed Broken. Tried Everything I can think of. (6 posts)

  1. Chris
    Posted 4 years ago #

    At some point in the past my RSS feed broke on my Blog. I have scoured the forums and google and tried everything I have seen to fix this from deactivating all plugins, deleting extra lines in the code, reinstalling all the core files and trying a different theme. Still, no luck. The blog link is http://www.moorewebexposure.com/blog/ and the RSS feed link is http://www.moorewebexposure.com/blog/feed/.

    The output error reads:

    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://www.moorewebexposure.com/blog/feed/
    Line Number 2, Column 1:

    and then it says:

    <?xml version="1.0" encoding="UTF-8"?>

    I have been trying to fix this for several months now and I just cannot figure it out. Hoping someone here might have some insight. Thanks a bunch!

  2. kmessinger
    Forum Moderator
    Posted 4 years ago #

    The parsing error comes from a blank line or a open space in some php file you have opened. You are on the right course but you just haven't found it yet. Have you tried this plugin, http://wordpress.org/extend/plugins/fix-rss-feed/ ?

    [Edit] Yes, it works ok in a reader but not stand-alone. And there are errors in the site, http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2fwww.moorewebexposure.com%2fblog%2f

  3. Chris
    Posted 4 years ago #

    Thanks for the quick responses. Yes, I am aware the site does not validate... I am sure a few of them may be legitimate but most errors are from plugins up to no good.

    I actually replaced all the core WordPress files with a brand new installation and even swapped out my wp-config files and still no luck. I did try the fix-rss plugin and no luck. Guess I will just have to keep poking around to figure this one out.

  4. Chris
    Posted 4 years ago #

    So this is very strange. I believe the problem resides in my database if that is possible. I reinstalled EVERYTHING and when I added my posts table to the database is when it broke the RSS feed again. And when I dropped the table, the feed remained broken. Very odd to me.

  5. Chris
    Posted 4 years ago #

    OK so after a whole new wordpress install, which i probably needed anyhow, i seem to have gotten the RSS feed working. Unfortunately I could not narrow down the problem for others but at least I got it working.

Topic Closed

This topic has been closed to new replies.

About this Topic