Support » Fixing WordPress » rss feed broken and all links to posts dead after update to 3.4.2

  • I updated WordPress to 3.4.2 on 9/20/12 and since discovered that the rss feed broke and none of the links to individual posts are working, neither the links on the front page of the blog nor from the feed. My blog is at Google Analytics shows a pittance of visitors (0-3/day) since the 20th, when I usually get dozens of visits each day (30-100). Syndication to Facebook via Networked Blogs is no longer working. Error Message: “Error accessing this link! Please verify that it’s valid, and that your site is up. Websites that are too slow might also be inaccessible, in which case you might want to check with your hosting company.” The site is up, and I was using this feed url:

    Using does not work, NWB says it cannot read the feed.

    Using my Feedburner feed url, the feed is detectable, but there’s an error saying the posts are not legible, so it also does not work and Networked Blogs cannot syndicate it. In addition, the post title links on my Feedburner feed return 404 NOT FOUND error pages and do not send people to the blog at all. If you go to the blog and compare the entries to the Feedburner list of posts, you can also see that entries posted after 9/20 are missing.

    Just reinstalled 3.4.2 and ran the rss-feed-fix plugin, but still no feed and all links to individual posts are still returning 404 not found errors.

    I need help with this one! Thank you for your attention and assistance.

    [No bumping. If it’s that urgent, consider hiring someone.]

Viewing 4 replies - 1 through 4 (of 4 total)
  • I posted this elsewhere and a moderator told me to open a new topic.

    This morning I read the topic on updating WordPress and got the idea that I might be missing something in my .htaccess file. I then read the Permalinks and .htaccess topic and found the permalink lines that should be included, checked .htaccess and found them to be missing. Edited .htaccess with high hopes that this would work, but I still can’t navigate to a post from the front page – I just get a different 404 Not Found error page with no styling.

    Next is to try re-updating manually. It seemed like some people here in the forum had some success with other problems after the 3.4.2 update by doing this. I’ll let you know how it goes. All this and I have the Permalink Finder plugin installed, which is supposed to prevent this sort of thing, but maybe it’s not able to do its job since ALL my permalinks are not functioning? In any case, if a manual update doesn’t do the trick, I’ll have to roll back to a previous db export from before the update and repost the new entries created since the update. And wonder if I’ll ever be able to update this blog again – I have other blogs that have experienced no trouble since the 3.4.2 update (as far as I know now!) but this one, my main one, is really battling me.

    Decided to roll back to a previous database export to see if I could figure out exactly when the problem occurred. To my surprise, I went back to before the problem began and found I still couldn’t navigate to any posts from the links on the home page excerpts. So I don’t know what’s going on with the links, but I suspect that whatever it is, that’s what is causing the rss feed to fail. I’ve restored my database to include recent posts and deleted all new plugins I had installed to try and fix the problem. Not sure what to do next. Maybe I’ll try the manual update now.

    Kinda feel like I’m talking to myself here. Hopefully this minijournal of this experience will help someone in the future.

    Well, somehow I got it to work. I did the manual update and the links were still not working, but by the time I had re-activated the plugins and returned to the blog’s front page to see what it was doing…I could suddenly click any link on my home page and it actually took me to the post! I’m sorry I can’t be more specific about how or why this worked, but if you have a problem similar to this after an update that you did from within your WordPress admin area, I suggest the manual update. By the way, I never did mention that all the links and functionality in my admin area remained live during all this trouble, which was a rally. I understand several people who hosted their blogs with GoDaddy were locked out of their dashboard/admin after the 3.4.2 update, but this was not the case with my blog. TG!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘rss feed broken and all links to posts dead after update to 3.4.2’ is closed to new replies.