Support » Plugin: Seriously Simple Podcasting » RSS Feed 404 Error When There Are No Posts

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Hugh Lashbrooke

    (@hlashbrooke)

    Hi Colin,

    I’ve noticed this before as well. As far as I can tell, this is nothing to do with my plugin – that’s just how RSS feeds work. If there are no items in the feed then it will return an error and there doesn’t appear to be any way around that no matter what feed solution you try to use.

    If I ever come across a work-around for this I’ll implement it in the plugin, but as far as I know it won’t be possible.

    Hi Hugh, thanks for getting back to me.

    I understand that this is the case when you’re looking at the feed which is empty, but I’m finding that having an empty posts feed stops the separate Podcast feed from working too.

    So, I have a few Podcasts posted, so that feed contains, say, 3 items, but there are no posts so that feed’s empty. That empty posts feed seems to stop the Podcast feed working too, even though it contains a few items.

    Is that WordPress overriding the SSP feed to cause trouble…?

    Thanks,
    Colin

    Plugin Contributor Hugh Lashbrooke

    (@hlashbrooke)

    OK – I see the problem now. Let me do some research into this over the next few days and I’ll get back to you. I imagine this will be a WordPress issue and not something specific to the SSP feed, but I’ll see what I can dig up about it all.

    In the mean time maybe do a bit of debugging on your side – deactivate all your other plugins and see if that fixes things. If it does then reactivate them one by one until the feed gives the 404 error again – if that happens then you’ll have found the problem plugin.

    I’ll update on here when I have more info.

    Excellent, thanks Hugh – I’ll let you know if I find anything!

    Plugin Contributor Hugh Lashbrooke

    (@hlashbrooke)

    Hi Colin,

    It looks like this is a WordPress problem, but it could also be related to any caching plugins you may have installed.

    This thread looks like it has a fix for you: http://wordpress.org/support/topic/sitemap-xml-feed-is-shown-but-404-header-added-by-wordpress-if-site-has-no-posts?replies=4 – I haven’t tested that yet, but it sounds reasonable. If it is a good fix then I’ll implement in the next update of the plugin.

    Plugin Contributor Hugh Lashbrooke

    (@hlashbrooke)

    Hi Colin,

    I have just released v1.4.2 of the plugin (you will receive an update notification in your WordPress dashboard soon) that contains a fix for this issue – it is caused by a bug in WordPress, but I implemented a work around for it. Please let me know if you are still receiving the 404 error from feed validators, but that should no longer be a problem.

    Regards,
    Hugh

    Hi Hugh, that’s amazing, thanks! I’ll get the update installed now.

    Cheers!
    Colin

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘RSS Feed 404 Error When There Are No Posts’ is closed to new replies.