Support » Plugin: podPress » RSS ERROR

  • Hello,

    When I enable the podpress plugin my general RSS feed is getting broken. I received the error

    This page contains the following errors:

    error on line 97 at column 152: EntityRef: expecting ‘;’
    Below is a rendering of the page up to the first error.

    I’ve found that by disabling podpress that my RSS works fine. Thanks,

    http://wordpress.org/extend/plugins/podpress/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author ntm

    (@ntm)

    Hello Terry,

    the error message alone is not helping very much in this case. Please post also the content of line 97 of the RSS Feed source code and mayb also the code of line 96.

    Thanks,
    Tim

    Hi,
    I’m also experiencing this issue. It’s down to there being a ‘&’ in the podpress media title/mp3. I know this because the offending line in the error message relates to a file with a ‘&’ in. If I go back into the post, podpress has automatically changed the ‘&’ in the title (and mp3 route) to ‘& amp;’ (without the space). If I simple ‘Update’ the post, this fixes the issue. Weirdly this doesn’t always happen. I have several MP3s with ‘&’ in and it happens on quite a lot of them, but not all of them.

    Summary: Look at the line in the feed that the error is referring to and work out what post it is coming from. Open that post in question. Click ‘update’. Refresh your feed. Problem solved.

    Obviously it would be better if the plugin performed correctly and you didn’t have to do this!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘RSS ERROR’ is closed to new replies.