The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

RSS Categories Feeds...just not happening - (7 posts)

  1. blksheep
    Posted 5 years ago #

    Hi -

    I'm desperately trying to figure out how to use an RSS feed for just the individual categories. I've tried every method but to no avail.

    I've succesfully coded a flash site in development to import the RSS with images (no easy feat!) into the flash. The main feed works great:

    however when trying to load category feeds with or any other url version,

    in flash its coming up blank; because when this feed url is loaded in a browser it loads the BLOG page, not the actual feed page. I can't for the life of me figure this out, how to load the indvidual category feed pages, just in a browser.

    I've deactivated every plug-in. Thanks for ANY assistance!

  2. jkovis
    Posted 5 years ago #

    hmm...the feed at http://amandlanet.net/amandlablog/?cat=1&feed=rss2 is loading fine for me.

  3. blksheep
    Posted 5 years ago #

    Yes, but it loads as a blog page, right? not an rss page, as does

    http://amandlanet.net/amandlablog/?feed=rss2 -

    with strait text/images in the rss page form, not the blog page form with the header, admin bar, etc which is why flash isn't parsing it correctly to be viewed I think.

    Shouldn't it load as does the main rss page?

    thanks -

  4. esmi
    Forum Moderator
    Posted 5 years ago #

    That url loads like any normal feed file for me too.

  5. blksheep
    Posted 5 years ago #

    Dangnabbit - Could you tell me what exactly you're seeing? Because for me, http://amandlanet.net/amandlablog/?cat=1&feed=rss2 loads like a blog-formatted page as I mentioned, with header, background color, sidebar etc. The main feed url http://amandlanet.net/amandlablog/?feed=rss2 loads as I would expect an rss feed.

    So are you saying both those urls loads identically as rss feed pages?

    http://amandlanet.net/amandlablog/?feed=rss2 - and - http://amandlanet.net/amandlablog/?cat=1&feed=rss2?

    Am I losing my mind? Don't answer that - but is there something I'm overlooking? A browser or WordPress setting?

  6. blksheep
    Posted 5 years ago #

    Solved -

    As I guessed, it was the syntax. The WordPress codex page is wrong - well not entirely, but it's not correct.


    is the url for the category feed, not


    which of course is the same thing, but what's supposed to be the html entity subsitute. Which for some reason for me, did not work, until I used the real '&' as opposed the '&'. I'm using Explorer 8.

    Hope this helps someone in the future, this was really agravating -

  7. jkovis
    Posted 5 years ago #

    You could also use a different permalink structure (wp-admin/options-permalink.php) and just add /feed to any page.

Topic Closed

This topic has been closed to new replies.

About this Topic