Support » Plugin: Rotating Tweets (Twitter widget and shortcode) » rotatingtweets element height problem (again)

  • Resolved zimbo000

    (@zimbo000)


    Martin,

    I have a problem here. Just noticed now that the rotatingtweets box has a ‘height: 347px’ attached to it and is causing the tweets box to be longer than the columns either side. I have not changed the plugin since our last discussion other than to update it to 1.9.1 today, which I did after noticing the problem.

    https://www.henleyherald.com/

    The full CSS is

    element.style {
        position: relative;
        overflow: hidden;
        height: 347px;}

    After the last discussion, tweet_count was 5 and carousel_count was set at 3. The outer twitter-box element was the same height as the columns either side.

    Today it’s about 5cm longer. If I change the count to 2 then twitter-box reduces to the same height as the other columns because rotatingtweets reduces from 347px to 232px. So without me changing anything with the plugin, twitter-box is 5cm longer today than 5 days ago.

    Do you dynamically alter the height of the box in the code depending on the tweet content? We’re only displaying retweets. One thought is that some RTs cover 5 lines, some are 4, others 3. So if all are 5 lines, and you are dynamically altering the rotatingtweets box size by interpreting each RT’s ‘height’, then that box would be bigger than if all the RTs are just 2 lines.

    Could this be the issue?

    I need twitter-box to stay at the same height all the time so it always matches the columns either side. I can do this via a fixed height CSS command on rotatingtweets but would like to understand if this is the problem, and would there be any knock-on effects of doing so?

    PS. I have changed carousel_count back to 2 to match the column heights.

    PPS. The http://dev.henleyherald.com/ site is still set at a 3 count if you want to see the problem.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Martin Tod

    (@mpntod)

    I’ve seen a way to a solution on this.

    In essence, I need to add an option to switch off height management by adding data-cycle-auto-height=false to the rotating tweet container.

    When I get a moment, I’ll add the option to the code.

    zimbo000

    (@zimbo000)

    Great Martin, thanks.

    Plugin Author Martin Tod

    (@mpntod)

    Does the development version solve the problem?

    Try adding auto-height=false or auto-height=-1 to the short-code.

    Plugin Author Martin Tod

    (@mpntod)

    Or auto_height=0

    (I’ve made it work the same way as the other options).

    • This reply was modified 3 months, 3 weeks ago by  Martin Tod.

    I’ve downloaded the development version but if I try to install it I get an error saying the plugin directory already exists and it fails.

    I’ve tried renaming rotatingtweets.php and uploading the revised dev version but that triggers a fatal error when I try to activate it.

    If I rename the existing directory the install would work but will I lose all the settings i.e. how can I get the dev version installed?

    Plugin Author Martin Tod

    (@mpntod)

    That sounds odd. You should be able to load it over the top of the current file.

    The only files that have changed are rotatingtweets.php and readme.txt.

    I’d suggest downloading the zipfile again – extracting those two files – and uploading again.

    Nothing you do should overwrite the settings….

    Re-upload failed again on activation, the error referenced the renamed file. Something must have been cached somewhere so I moved that file out of the directory, activation failed again, tried yet again and it worked. 🙂

    So it’s working. Please can you explain what this option/fix does to the rotatingtweets element?

    Plugin Author Martin Tod

    (@mpntod)

    The option will switch off resizing – so you need to set the container height via CSS instead!

    Probably something like:

    div.rotatingtweets {
        height: 300px;
    }
    • This reply was modified 3 months, 3 weeks ago by  Martin Tod.

    Ah, that was what I wondered – whether I needed to add some CSS as well as the new switch. I’ve done that and all seems fine now.

    Will you be releasing a new official plugin version soon with this feature in it?

    Plugin Author Martin Tod

    (@mpntod)

    Yes. I’ll check there are no problems and issue an update.

    Plugin Author Martin Tod

    (@mpntod)

    The update should be coming through now….

    Got it, thanks for doing this.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.