Support » Plugin: Email Subscribers & Newsletters » Roll back to 3.5.18 ERROR

  • Resolved domilo

    (@domilo)


    Hi,

    I tried to roll back to 3.5.18, because the new version doesn’t function properly… At the activation, here is the message :

    Fatal error: Uncaught Error: Cannot unset string offsets in /homepages/6/d775447695/htdocs/wp-content/plugins/email-subscribers/classes/es-register.php:478 Stack trace: #0 /homepages/6/d775447695/htdocs/wp-content/plugins/email-subscribers/classes/es-register.php(445): es_cls_registerhook::es_upgrade_database_for_3_2() #1 /homepages/6/d775447695/htdocs/wp-includes/class-wp-hook.php(286): es_cls_registerhook::sa_email_subscribers_db_update(”) #2 /homepages/6/d775447695/htdocs/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #3 /homepages/6/d775447695/htdocs/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #4 /homepages/6/d775447695/htdocs/wp-settings.php(505): do_action(‘init’) #5 /homepages/6/d775447695/htdocs/wp-config.php(94): require_once(‘/homepages/6/d7…’) #6 /homepages/6/d775447695/htdocs/wp-load.php(37): require_once(‘/homepages/6/d7…’) #7 /homepages/6/d775447695/htdocs/wp-admin/admin.php(34): require_once(‘/homepages/6/d7…’) #8 /homepages/6/d775447695/htdocs/wp-admin/plugins.php in /homepages/6/d775447695/htdocs/wp-content/plugins/email-subscribers/classes/es-register.php on line 478

    So I needed to go via FTP to delete the plugin.

    Any idea ?

    Thanks,
    Domilo

Viewing 13 replies - 1 through 13 (of 13 total)
  • Just rolled back without any problems. Have you deactivated and deleted the new version at first?

    https://wordpress.org/support/topic/rollback-to-email-subscribers-3-5-18/

    Yes, i did. Perhaps is there anything to do into the database ?

    I haven’t done anything in the database.

    Maybe it’s a php issue. Which version are you using for your site.

    How you installed the plugin? Via FTP? If not, try that.

    I can confirm that a rollback is possible without doing anything in the database. I’ve copied a backup of the plugin subfolder of “email-subscribers” into the plugin folder and named it with the version. I then had both versions shown in WP, which I could activate alternatively.
    Did you have a successfully finished conversion of you database after upgrading? I’ve clicked on the “run now” link in the dashboard after upgrade to have it really done now and not at some point later.
    Do you have a backup of your plugin folder with V3.5.18 of this plugin? If yes, then delete plugin folder and completely copy the 3.5.18 folder.
    Hope this helps!

    Here are the infos : WordPress 5.1 | PHP 7.2.15 | Apache | MySQL 5.5.60-0

    I tried to install via FTP, the same…

    Then I installed the 3.5.18, made the upgrade, then deactivate, delete, and upload the 3.5.18, and always the same error message…

    That’s why I think there is something in the database that is on v4, and does not match with v3…

    Answer to OLIVERMERK :
    Did you have a successfully finished conversion of you database after upgrading? YES

    Do you have a backup of your plugin folder with V3.5.18 of this plugin? YES and NO :
    when I saw that the v4 was not running properly, I replaced it with v3 (after deactivating and deleting), but when v3 activated, the dashboard remains with the v4 options… So my backup is with this configuration.
    I restored all with this backup, but now I cannot activate the v3 without having this error message.
    That’s why I thought of going into the database and change something, but what is the question 🙂

    Thanks for trying to help !

    Your error gives a hint, where the problem comes from. It is line 478 in es-register.php. Check here: https://plugins.trac.wordpress.org/browser/email-subscribers/tags/3.5.18/classes/es-register.php

    It is a problem in the function “es_upgrade_database_for_3_2”. I don’t know why you are running through this code (I am no programmer of this plugin), since you have upgraded from 3.5.18 to 4.0. Or have you started from a lower version?

    Well, the function above in row 442 shows how it is decided, what has to be done with the database.

    if ( get_option( 'current_sa_email_subscribers_db_version' ) === false ) {
                            es_cls_registerhook::es_upgrade_database_for_3_2();
                   }

    So, it seems the option “current_sa_email_subscribers_db_version” is missing in your database.

    I hope your database is not corrupt with respect to email subscribers values.

    I have never done the upgrade again after reverting to 3.5.18. Maybe this has skrewed up some database values. You need an database expert from icegram to help you export the email subscriber relevant parts from your database, maybe edit it as needed an reimport.
    Or get help to delete all database values for email subscriber plugin from WP database (backup database first!) and start from scratch. Then restore the relevant parts by help of the DB backup. But this can be laborious without the right knowledge and tools.
    All the best!

    Thanks Docolli ! This will surely help, I’ll take a look deeper…

    Yes, it seems that the function in trouble is necessary for the 3.2 version database upgrade. This is kind of strange. If you look at the database at the moment you should have to sets of tables. One for the 3.xyz and one for the 4.xyz plugin version.

    3.xyz tables
    wp_es_[tablename]

    4.xyz tables
    wp_ig_[tablename]

    (wp_, the database prefix, can be different in your case)

    Everything stored in the 4.xyz tables may be available in the 3.xyz tables (except changes made after activating the 4.xyz version .

    I am not sure if it helps or if it is save to just delete the 4.xyz database tables after deleting the plugin. So yes, you should get back with the plugin developers to clarify this and get support. https://icegram.com/contact

    • This reply was modified 7 months, 2 weeks ago by  borisj.
    • This reply was modified 7 months, 2 weeks ago by  borisj.

    Hi Borisj,

    Thanks for your email…
    I took a look into the database, and compared it with another site of mine where the plugin goes perfect. I deleted the tables named es_ remaining, and in the options table, deleted all the records with option_name beginning with ig_es_.
    And now it works !

    Thanks 🙂

    Plugin Contributor Malay Ladu

    (@malayladu)

    @domilo @borisj @docolli @olivermerk We would like to thank you all for helping each other to rollback to ES 3.5.18.

    We are committed to fix your issues. We are constantly working on it.

    You can refer daily updates from here.

    Just want to update you that we have just released ES 4.0.3.

    Hi Malay,

    Thanks for your message…
    I will update the 3.5.18 with the new one when all will be ok ! The 3.5 works so fine…

    Regards
    domilo

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Roll back to 3.5.18 ERROR’ is closed to new replies.