Support » Plugin: Role Scoper » Role Scoper – Private post reader not working

  • I’m unable to see posts that are marked private, even if logged in as a user included in the RS ‘Private Post Reader’ assignment. (Under Roles – General. Have tried adding the user as well — no change.

    On the RS Posts assignment page, I’ve assigned all my logged in users — who should be able to see private posts — as Post editors for existing and new posts. My RS Post restriction page shows Unrestricted for post readers.

    So I’m stumped as to why private posts are not visible to those permitted. Any help would be most appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • I think this turns out to be a WP core feature, and not a RS problem. I can uninstall RS, and switch to plain ol TwentyEleven, and still get the problem when using the ‘Recent Posts’ widget. The problem goes away (private posts show or don’t show properly) when I do Settings->Reading (options-reading.php) and enter a specific page for posts.

    I just need to find out how to get that proper usage either in the widget or shortcode, or code code! i.e. display all posts as long as authorized!

    I was tempted to mark this closed, but it still seems from the RS interface that users added in RS ‘Private Post Reader’ (under Roles – General) should have permission elevated to see private posts. That is not the case, and a very nice feature to have working.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Role Scoper – Private post reader not working’ is closed to new replies.