WordPress.org

Support

Support » Plugins and Hacks » Role Scoper » [Resolved] Role Scoper Gives Warnings after PHP upgrade

[Resolved] Role Scoper Gives Warnings after PHP upgrade

  • Heyy,

    After upgrading PHP to version 5.4.3, I have been getting multiple warnings:

    Warning: Creating default object from empty value in /wp-content/plugins/role-scoper/definitions_cr.php on line 57

    Warning: Creating default object from empty value in /wp-content/plugins/role-scoper/taxonomies_rs.php on line 37

    Warning: Creating default object from empty value in /wp-includes/capabilities.php on line 598

    Warning: Creating default object from empty value in /wp-content/plugins/role-scoper/query-interceptor_rs.php on line 296

    Is this a known issue? Is there a quick fix?

    http://wordpress.org/extend/plugins/role-scoper/

Viewing 4 replies - 1 through 4 (of 4 total)
  • I am getting the same warning from capabilities.php (don’t have Role Scoper), and in addition I cannot log in. My attempts at debugging seem to indicate that some subtle change in handling of magic methods (__get, __set, __isset etc.) in PHP 5.4.3 broke the WP_User class, so this seems to be a deep problem. I will probably file a ticket on WordPress trac later this night.

    Did you figure this out? I have the same problem with Role Scoper. I bought Googlyzer Pro and it requires php5.3 or higher and that screws up Role Scoper which is a big part of my site.

    No luck yet

    Plugin Author Kevin Behrens

    @kevinb

    PHP 5.4 warnings are fixed in Role Scoper 1.3.56

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Role Scoper Gives Warnings after PHP upgrade’ is closed to new replies.
Skip to toolbar