Support » Plugin: User Meta - User Profile Builder and User management plugin » role not applied, extra field not visible in backend

  • Resolved violetta

    (@violetta)


    Hi there,

    Thank you so much for making this plugin. I spent the whole day yesterday converting my system from profile builder to yours and planned to write a thank=you note today,

    But then I discovered from checking the overnight registrations that some things are *not working*.

    First thing not working is that the users who are today registering for a specific class are being registered as subscribers, instead of the role I have assigned to them. I have the role input hidden, but it’s not working!

    Second thing not working is that I have created a created an extra field for the user’s city. But I can’t see this on the back-end looking at the user’s profile.

    Also I like that you allow Avatar, but it’s also not showing up on the back-end unless I have an additional plugin installed.

    Finally, I have just modified one of the forms, and then tried to view it in incognito mode and three devices and the updates don’t show. see https://tangoforge.com/credential/challenge2020. Do you see there’s no email field? I’ve added it to the form, but it’s (so far) not appearing.

    Thank you in advance for your help.

    • This topic was modified 1 year, 11 months ago by violetta.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Sourov Amin

    (@sourov)

    Hello,

    For the role problem, make sure you have configured the Role field correctly. Make sure to choose at least one role for “Allowed Roles” and select a “Default Role” from the allowed roles.

    To add an extra field to the backend-profile, make the field as a shared field and then add that field from “User Meta >> Settings >> Backend Profile”. That should do the job.

    It seems the email field is there in your provided URL.

    If you still have issues left please let me know.

    Thanks!

    Thread Starter violetta

    (@violetta)

    Hi there,

    The roles were configured as you stated, but did not work.

    The meaning of “shared” was not at all clear! Thank you for responding, but just to let you know, before receiving your response, I got the sense from your docs that I was allowed to create custom fields in the free version but only view them in the pro version. That felt like a bad trick. On that basis, although I was a few hours before about to buy the pro version because of the role assignment possibilities, I decided instead not to use your plugin. I switched to Advanced Custom Fields with Front-end for Elementor.

    So I recommend for your future success that you clarify both the issue of whether viewing custom fields in admin is a free or pro feature, and also how to do it.

    Violet

    Plugin Author Sourov Amin

    (@sourov)

    Hello,

    Sorry that your experience with User Meta was not good enough.
    Also thank you for the suggestion about Shared Fields.
    Up until now, you can not actually create custom fields with the free version, unless you have installed the pro version and somehow deactivate the license. Although from the upcoming free version almost all the fields will be available in the free version too.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘role not applied, extra field not visible in backend’ is closed to new replies.