WordPress.org

Forums

Role Manager and WordPress 2.8 - Is plugin now obsolete? (8 posts)

  1. mrsolutions
    Member
    Posted 5 years ago #

    I've been using Role Manager on my wordpress blogs for some time, but the plugin has not been updated for a while and I've heard it has issues with newer versions of wordpress.

    Is the plugin and its functions now obsolete in wordpress 2.8 and are there any alternatives that are compatible with 2.8?

  2. joshmac
    Member
    Posted 5 years ago #

    I am using it with 2.8.2 without any issues.

  3. Justin Tadlock
    WordPress God
    Posted 5 years ago #

    If you are looking for an alternative, I'm taking ideas and suggestions for something similar but more robust right now. Feel free to offer feedback.

    As far as I can tell though, Role Manager still works fine with the latest version of WP.

  4. mrsolutions
    Member
    Posted 5 years ago #

    @greenshady

    What you are making sounds good.

    The problem with role manager is that it is not being updated, and will likely start to break down. For some people its already not working in 2.8. It is fine for me though so far.

    One problem is that removing the Role Manager plugin is difficult because it keeps the old rules, and once removed you can't edit them without the plugin. If it becomes buggy this could be a real pain.

    So for you plugin if it could work with a previous Role Manager setup that would be handy.

    Otherwise your plugin looks very good.

  5. darknailblue
    Member
    Posted 5 years ago #

    The rolemanager plugin DOES NOT work as it should - please be advised that when a custom role is created it does not function as should especially when being integrated with other plugins that used to take advantage of this functionality. Another simple test is merely to create a new role and hide most of the WP core function. Notice how most of the options are still available.

    This has been an issue since 2.8.

  6. hyperzahranism
    Member
    Posted 5 years ago #

    I'm using wp mu 2.8.6, when i tried to activate the role manager plugin I've got this message

    Parse error: syntax error, unexpected $end in /home/site/public_html/wp-content/plugins/role-manager/general.php on line 99

    it's not working, but is there any way to fix it

  7. besimmikullovci
    Member
    Posted 5 years ago #

    I am trying to let users modify – edit published pages without having possibilities to create new ones, and it is possible for me to do this…
    So, I would create pages and users would have possibilities only to modify (change text pictures)… can anyone help me resolving this matter?
    Thank you in advance…

  8. funhomeboy
    Member
    Posted 5 years ago #

    Does not work correctly with 2.9.2. I tried editing the roles to allow the user to only edit their posts but when but the correct settings in the edit button does not show up for the user, only works when allow edit other pages is selected (which kind of defeats the object).

Topic Closed

This topic has been closed to new replies.

About this Topic