Support » Networking WordPress » Robots.txt not generated with subdir multisite

  • Hi everyone!

    I am using a WP 3.0.1 Multisite network using subdirectories. This works pretty well, but there is a issue left that is pretty important for me:

    The subdirectory blogs do not output a robots.txt. This is no problem when using them as subdirectories, since only the root robots.txt is used.

    But in combination with the domain mapping plugin this becomes an issue, because the mapped domains do not have a robots.txt.

    I tried this with a multisite setup using subdomains, there robots.txt files are created when looking for them on the mapped domains. But I can’t use this setup productively at my hoster.

    Any ideas how to fix this?
    Thanks!
    Dennis

Viewing 3 replies - 1 through 3 (of 3 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    What exactly are you trying to do where you need different robots.txt files for each domain?

    I am trying to specify the location of sitemap.xml for each blog.

    If there is any other way to do so it would be great if you could tell me how to do it.

    Thank you very much!
    Dennis

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Use a sitemap plugin that works with multisite.

    Yes, they exist in the repo. (I personally don’t find them necessary but to each his own)

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Robots.txt not generated with subdir multisite’ is closed to new replies.