Support » Fixing WordPress » robots.txt missing after URL Change

  • Today I got a new toplevel domain and changed my wordpress blog to it (from my old domain). I used the plugin search and replace, in order to change the URLs in the entire blog.
    The server did not change, just the URL.

    I registered my new domain to google analytics, pasted the new code etc.

    But then I discovered the robots.txt is not created automatically anymore!

    Of course I could just upload a new robots.txt, but I am afraid something went wrong. Yesterday my robots.txt was working!

    Today I (and google) just receive a 404…

    Any suggestions? I already searched the complete day for a solution.

    FYI: privacy settings are set to visible, .htaccess is empty:

    # BEGIN WordPress
    # END WordPress

    and permalinks are set to standard

  • The topic ‘robots.txt missing after URL Change’ is closed to new replies.