WordPress.org

Support

Support » How-To and Troubleshooting » [Robots.txt] Custom robots.txt not working

[Robots.txt] Custom robots.txt not working

  • Hello,

    I’m trying to create a custom robots.txt. But when i upload it to the root of my blog, it doesn’t overwrite the standard robots.txt that wordpress auto-creates (there is no robots.txt in the blog root), instead, it gives an error that robots.txt cannot be found…

    I think it has something to do with the .htaccess file, because it also automatically adds an end-slash like: example.com/robots.txt/

    Hope someone can help me 🙂

    — BEGIN .htaccess —
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    — END .htaccess —

    Greetings

Viewing 1 replies (of 1 total)
  • Summary:
    There is a robots.txt, but i can’t edit it, because its somewhere auto-generated by WordPress. (i have read that somewhere)
    So, i try to upload my custom robots.txt to my blog’s root. But when i do that, and i request the robots.txt trough a browser, i get an error that the page cannot be found. (it also automatically adds an end-slash like: example.com/robots.txt/)
    When i have deleted my custom robots.txt, i get the standard auto-generated robots.txt from WordPress…

Viewing 1 replies (of 1 total)
  • The topic ‘[Robots.txt] Custom robots.txt not working’ is closed to new replies.