Support » Plugin: Photo Gallery by 10Web - Mobile-Friendly Image Gallery » Robots noindex tag on gallery pages

  • Resolved dromanov31

    (@dromanov31)


    Hello!

    Since 4th February gallery pages has started to disappear from search systems because of robots noindex tags. I didn’t change configuration of any SEO parameters.

    How can I fix this?

    Thanks in advance!

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support kimabaghdasaryan

    (@kimabaghdasaryan)

    Hi,

    Please note that we have excluded custom posts after 1.5.15 version.
    However, if you want to include them, you can contact us via support@10web.io Email address, and we will send you a version of the Photo Gallery Plugin where custom posts are included.

    Thank you!

    Have a nice day!

    dromanov31

    (@dromanov31)

    Thanks for clarification!

    detoris

    (@detoris)

    What are the reasons for this change and what will you implement in the future for good SEO support?

    Plugin Support kimabaghdasaryan

    (@kimabaghdasaryan)

    Hi,

    Please note that you can implement the following solution.

    Please navigate to photo-gallery/photo-gallery.php file, search for public function create_post_types(), you should change public function create_post_types() to ‘exclude_from_search’ => FALSE but where ‘public’ => TRUE is written.

    For example, our developer has highlighted the line which should remain as true:

    https://gyazo.com/9e969f09e57ab11e07ea7981f7ac8ba9

    Please let us know if it helps.

    Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.