Support » Themes and Templates » right-side stuff pushed way down in 1.2.2

  • I have somehow messed up my index.php (I think) so that t right-side items that should be only a little ways down from the top are way, way, way down just past the last line of the last post in IE. In FireFox it’s a bit different but not right.

    I’ve spent most of the day checking out and experimentally moving/removing </div> tags and other formatting, to little or no benefit. I’m at the point where it’s all running together in my mind and I’m getting a headache.

    Here’s the really maddening part: If I click on comments to get the single-post comments page view, voila! The dadblasted right-side stuff is right where it’s supposed to be. (Knuckles going white, temples pounding . . .)

    I’m hoping maybe someone who’s been in this fix will be kind enough to point out the incredibly simple, obvious thing I’m too flummoxed to spot and fix.

    I have a 1.5 test blog up now, but I’d like to be able to keep publishing on the 1.2.2 one until I’ve had some time to get acquainted and adapt my theme to the shiny new 1.5 setup.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I should’ve mentioned, the URL is

    Have you tried validating it using the ‘show source’ checkbox on the W3C end? It would probably take a while, but if you were to clean up the missing end tags and so forth, the real problem should stand out where you can see it.

    Thanks, Pericat, but I can’t get into the admin page since I installed a WP 1.5 test blog in another directory. I can get into the new one just fine, but I get only error messages when I try to get into the old one.

    Warning: main(auth.php): failed to open stream: Permission denied in /home/xxxxxxx/public_html/wpblog/wp-admin/index.php on line 4

    Fatal error: main(): Failed opening required ‘auth.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/anderson/public_html/wpblog/wp-admin/index.php on line 4

    I used Fantastico to install the new 1.5 and I think it somehow changed the siteurl associated with the existing blog as well as the new one, although I don’t know because I specified a new, different directory.

    Validate your page. With 317 errors, you might fix something.

    If you validate and that doesn’t work, then your sidebar is probably floated right and is too wide. Try the validation first. That’s a lot of errors.

    Thanks for the responses. I’m gaining on it. I restored a slew of files in the main WP directory and in wp-admin, which did the trick. Whew.

    Here’s the big sticking point now, the thing that I hope some more-experienced WP user here might be able to help me sort out. The page displays just right in the single-post page view that comes up when you click Comments. It’s only screwed up in the multiple-post page that you surf to.

    I’ll give the validate thing a try. Just hope it doesn’t trigger any addtional setbacks right now. When I had auto validate set on in the blog, I had problems with it because I’m doing some custom formatting in css using paragraph span style. As I recall, the auto closing tags thing was throwing in extra closing paragraph tags, or something like that. It nearly drove me crazy until I notice I could turn it off.

    Related question: I can’t get either Firefox or IE6 to let me View Source on WordPress pages, not on my blog or others I’ve visited. How the heck do you do that? Is there a setting in the blog or the browser I’m missing?

    All help gratefully accepted.

    Depends on which source you’re trying to see. What the browser’s ‘view source’ will show is the end product, the HTML. Not the php code that generates the HTML.

    The validation we’re talking about has nothing to do with the auto-validate and so forth in the Admin’s composition panel. We’re talking about the ‘Valid XHTML’ link in your sidebar. Toward the bottom. It’s a link to the W3C’s validator. Your index page generates a ton of errors, mostly to do with failing to close breaks, list and image tags as per XHTML specs. If you can clean those up, the real problem you’re having with the difference between the display of the index page and the display of the single post page should be easier to see.

    OK, I went to the validator. I ran it on both the main blog page and the comments/single-post version. I had it show source and copied each to a text file. Now, maybe I can spot something missing or out of line.

    I’m thinking it has to be that there’s some coding or something at the end of the “Just say it!” execution box that goes below the comment entry form, that’s missing from or incorrect in the main page.

    The problem is, the text files generated are really big (sigh). Kind of like looking for a lost dime in the Grand Canyon.

    One other thing, while I’m at this. The validator got huffy about not declaring open tags (or something like that) because, evidently, I don’t have a
    for every <br>. That’s the great bulk of that big errors total.

    I noticed a bunch of other errors come right out of what WP puts in and from the JS code, or related HTML, for a couple of add-ins on the page â€? things I don’t think I can do anything about.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘right-side stuff pushed way down in 1.2.2’ is closed to new replies.