Support » How-To and Troubleshooting » [Resolved] Rich text editor…gone?

[Resolved] Rich text editor…gone?

  • Recently (just a few days ago), my rich text editor on WP stopped working. Now it’s just the basic editor that shows up. As far as I know, I haven’t changed any options that might affect this (all the right boxes are checked and so on), so I have no idea why the rich text editor would not show up. This problem shows up in both Firefox 2 and IE7, so it must be something with my copy of WP. A plugin perhaps? Any help would be great because I miss my rich text…

Viewing 15 replies - 1 through 15 (of 35 total)
  • A plugin perhaps?

    Well, *have* you installed any plugins that might futz with the editor? We have difficulties here on the support forums when it comes to divining that.

    Something to check in your browser is to see if you get any javascript errors related to TinyMCE (that’s the ‘rich text’ editor WordPress uses) when in your post editor.

    Something to do to try and resolve this, assuming it’s script file-related, is to delete everything found in wp-includes/js/tinymce/ and do a full reupload of the directory and its subs.

    None of the plugins I’ve installed recently should affect TinyMCE, but I deactivated them all just in case. No effect there not even when I delete and re-uploaded the TinyMCE directory.

    Anyways, here’s a list of the plugins I’m using. Maybe there’s something about one of them that I’m not aware of:

    *Creative Commons Configurator
    *Improved Include Page
    *Random Quotes
    *Viper’s Video Quicktags
    *WordPress Database Backup

    you know you can select to use the fancy editor or not for each user? go to the bottom of the profile page and be sure rich text editor is in fact ticked. If it is, untick it then save and then retick it on a subsequent save perhaps?

    I tried that, but still nothing.

    But, I have come across some things that may help in figuring out what’s going on:

    Today when I was writing a post, I noticed that the FireBug plugin in Firefox was giving me two errors on the Write New Post page. The first error says “invalid flag after regular expression
    tiny_mce_gzip.php… (line 709)” and gives this:

    <b>Warning</b>: file_get_contents(/usr/home/logan/public_html/blog/wp-includes/js/tinymce/plugins/buttonsnap/editor_plugin.js) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory in <b>/

    The second says that TinyMCE is not defined in post.php (line 188).

    Now, I checked and, sure enough, there is no editor_plugin.js file in the buttonsnap directory. Heck, there’s not even a buttonsnap directory. Never was. So why is the editor trying to get a file that was never there in the first place?

    >> *Viper’s Video Quicktags

    Pretty sure it uses the Buttonsnap js library.

    There isn’t a buttonsnap directory…. it’s just buttonsnap.php (one file unless things have changed lately….)

    Hmm, I used the video quick tags plugin for a little while before TinyMCE disappeared. I tried deactivating and even deleting the plugin, but the problem is still there.

    So, any other ideas?


    My Rich Text Editor has also stopped working. I’ve deactivated all plug-ins, and deleted and re-uploaded the TinyMCE directory.

    In the javascript console it says ‘TinyMCE not defined’ – any thoughts?

    The only thing I’ve done recently that may have caused this is change the blog files’ main directory?


    Oh, hey, I did that too. I don’t know if TinyMCE quit working then or not, but I did set the blog URL to mydomain.com where WP is located at mydomain.com/blog.

    I’ve sorted it. My problem was related to the fact that I had switched wordpress files into my top-level directory from /blog, without first reading this.

    I’ve transferred the files back into /blog, and set up the blog address in ‘Options’ to be http://www.strangerpixel.com, while the WP address is http://www.strangerpixel.com/blog. Then I copied the main index.php file back into the top-level directory and amended ./wp-blog-header.php to ./blog/wp-blog-header.php. Now TinyMCE is back in action.

    All right, I upgraded to WP 2.1, which I thought would eliminate the problem (yes, it’s still there). But even though the entire wp-includes folder was deleted, I still don’t have a visual editor. Is it a database thing? And if so, how could I fix it?

    Same problem here 🙁

    For me, after upgrading with WP 2.1… it’s ok in IE7 but not with Firefox… !? Still can’t get formatting buttons, and can’t get tabs (Visual/Code)

    Very very strange…

    I found a temporary fix for the formatting buttons not showing up in 2.1: turn off the visual editor option in your user profile. That will bring back the basic formatting tags, but still doesn’t do anything for the visual editor.

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘[Resolved] Rich text editor…gone?’ is closed to new replies.
Skip to toolbar