Support » How-To and Troubleshooting » Rich Text Editor problem in WordPress 2.1.2

Rich Text Editor problem in WordPress 2.1.2

  • I’m new to wordpress and installed the blog today with my GoDaddy.com hosting control panel.

    Everything seem to be working perfectly, but I want a rich text editor to post messages in my blog. In the message posting page I can’t see any text formatting toolbar.

    I searched the support forums here and some of you have instructed to press the Alt+Shift+V key for firefox and Alt+V for IE to enable the Visual editor in the post page.

    I tried so many times(with cursor focused in the textarea) in firefox and IE, every time I press the key combinations, only the View menu of the browser is popping up. In windows (Alt+V) is a well know shortcut to access the view menu from the keyboard, I don’t know how this shortcut will work for wordpress script.

    I tried deleting the js folder and reuploaded it. Cleared the browser cache and checked. No changes.

    I also double checked the Users -> Your Profile page to make sure that the “Enable Visual Editor” checkbox is checked.

    I can’t figure out where the problem is. I’ve heard that WordPress is the best blogging system as far as simplicity and flexibility. But sadly it doesn’t seem to be the case for me.

    Can anyone help me to enable rich text editing in the posting page?

Viewing 12 replies - 1 through 12 (of 12 total)
  • It would be helpful to know what you DO see, don’t you think?

    Would you consider sharing a screen shot?

    Here is the screenshot of the post page while viewing it in firefox latest version.


    What personal firewall is installed on your PC?

    What happens if you temporarily disable it?

    I’m using ZoneAlarm firewall. I disabled the firewall, restarted the browser and tried using the shortcut Alt+Shift+V in the post page. Not working. 🙁

    If you need the access of the admin area of my blog, I don’t mind giving you the username and password. Can you give me your email address to send the login details or send me a sample mail to natkarthik@gmail.com

    Thank you.


    I have a suspicion this might track back that firewall**, but I’m willing to log in and have a look.

    ** seems there were some folks noticing differences between ZA Pro and the free version

    I’m using the pro version of ZoneAlarm firewall. Anyhow I’ve sent you the login details of my blog to your gmail address. Please have a look and let me know if there is anything wrong. Thank you.

    The “good” news is that I see what you see.

    So… this forum search may turn up useful posts?

    I’d probably start by suggesting a clean re-upload.

    I went through the posts in the “forum search” and I think lot of people have the same rich text editor problem as I have.

    But sadly, no body has found a solution yet.

    As I already mentioned in my first post, I’ve completely deleted the wp-includes/js folder and did a fresh upload. But nothing worked for me. If you want me to do a fresh re-upload of the js folder again please let me know.

    Please guide me on what I should do next. Thanks.

    Hi natkarthik,

    Does your browser report any javascript errors in the editor?

    From what I’ve seen most of these tinyMCE problems are usually due to caching, either your browser cache or server side proxy caching which can be a bit more difficult to clear.

    Then there’s the browser specific errors where it works in firefox but not in explorer or vice versa. Could be cache or one of various bugs depending on what versions you’re running.

    With wp 2.1.x though there’s also a new problem cropping up on some server/php combinations where realpath is undefined and tinyMCE file_get_contents throws an error. It’s mainly affecting plugins that load external buttons to the rte though but might also be a problem for some wp installs. This one is as yet unresolved but is in trac with a fix scheduled for wp 2.1.3 that could make a difference… hopefully.

    The problem here is that tinyMCE is a moving target and while the upgrade to the version in wp 2.1 fixed a lot of problems and is a lot more refined than the version in wp 2.0 it’s still a work in progress.


    Thanks for your response. I get the javascript error “tinyMCE not defined” when the writing page is loaded.

    I also did the modifications in the wp-includes/js/tinymce/tiny_mce_gzip.php as mentioned in the page you have given. Then I tried using writing page again by clearing the cache. But the same error occurs this time too.

    It appears to me that, there is not a known solution for this issue. May be the next version could fix this.

    Can anyone suggest me a good plugin for the rich text editing. Thanks.

    If by “rich text editing” you mean something to replace tinyMCE then try Google. I think Dean’s FCKeditor for WordPress might be okay for 2.1.2.

    Since the Visual Tab works usually fine when you go to the write page with a clean browser cache but will be stuck in code view once your browser cache has loaded the post-new.php page once it suggests that this may be cache related.

    Since it worked fine in 2.1.1. I’d check anything cache related that changed from 2.1.1 to 2.1.2.

    From a usability point of view this has a huge impact on your general user base t least as far as the wp.org community is concerned. Wp.com users aren’t affected anyhow.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Rich Text Editor problem in WordPress 2.1.2’ is closed to new replies.