WordPress.org

Support

Support » How-To and Troubleshooting » Rich Text Editor Problem – 2.1

Rich Text Editor Problem – 2.1

  • I have posted my problem in other threads, but don’t want to hijack anything that other people need help with.

    I have tried every solution to get my rich text editor working. When “Enable Rich Text Editor” is checked (in the correct place, users/profile) I see the two tabs. These are not clickable. There is no other options for formatting or anything. I have done the tiny patch said to fix this. I have completely replaced the wp-includes. I have refreshed my cache. I have disabled plugins. I have tried different browsers. I have tried all different combinations of my javascript options in my browser (FF 2.0.0.1). What else can I do? Is this just not fixable for some people?

    Any ideas at all about what I should do?

Viewing 15 replies - 1 through 15 (of 24 total)
  • I’m experiencing the same problem. Gone through the whole forum, but it looks like people problem limits to fail to check the “use rich text editor” checkbox in their profile.

    But, finally someone who is experiencing the same problem 🙂 I’m not alone :)))

    I’ve checked the generated page. Text editor javascript has the post/page’s content as a variable. So the problem is related to TinyMC.

    For the time being, I’m working with the basic text editor. I guess, will do till there is some kind of fix.

    Goodluck Uzbek.

    ME TOO!, i’m having the same issue!, how do we report a bug!?!?

    Same issue here. Also think it’s TinyMC. But problem only occurs with IE6. FF2 and IE7 are working fine.

    I just disabled the visual editor in my profile and then everything works fine. Thanks for the tip!
    But would be best if the visual editor works…

    I have the same problem, rich text is enabled only when editing comments, and just now I disabled it in the profilewith the effect that now appears the editing bar with all buttons…the bug seems to be there.

    My friend had this same problem when I updated her blog. The problem was solved when she updated her browser (Firefox) from version 1.x to 2.0.0.2

    I had the latest version of Firefox when updating and there was no problem with anything.

    I have the same problem. It happens only with IE6 on one of my machines. In Firefox is working fine. I have another machine in which TinyMCE is working fine. Very strange.

    Moderator Andrew Ozz

    @azaozz

    Similar problems here… In FF 2.0.0.2 Tiny starts ok but if I hit ‘Save and continue editing’ Tiny disappears. If I reload the page – it comes back…

    Its even more weird in Opera. Tiny works fine but If I edit a post there, Tiny turns sone html tags to uppercase and the page doesn’t validate as xhtml because of that! All HREF, IMG and some others are saved in uppercase in the database…

    (I have all disk cache set to zero in both browsers)

    having the exact same problem here on a brand new installation of WP 2.0.3 using FireFox 2.0.0.3. It works in IE7. This is a pretty major problem, and I imagine a large portion of the WordPress community uses FireFox.

    any updates?

    Why would you have a “brand new” 2.0.3 install when the latest in the 2.0.x series is 2.0.10?

    I imagine joelion meant 2.1.3 here, but I could be wrong.

    I have been trying to solve the visual editor problems for weeks now. I’ve tried just about everything put out by the community. Now I’m moving back to 2.0.10 until things are more stable with the 2.1 series.

    yeah, i meant 2.1.3 – i just downloaded it yesterday.

    but back to the problem. this is a pretty major problem, and that it hasn’t been fixed (or that is was introduced in the first place) is a bit disconcerting to me. I’ve been using WP since pre-1.5 days and I have seen a good many bugs last WAY too long and “blatenly obvious missing features” remain unimplemented, but this takes the cake. One of the most important aspects of developing a webapp is testing it across all platforms, in this case, all popular browsers. Since WP 2.0, the rich text editor is a key feature for the whole program, and should therefore be garunteed to work in all major browsers. Obviously, Firefox 2 is a major browser, so either 1) the rich text editor was not tested outside of IE, or 2) the problem was/is known, and just simply remained unfixed. Either way, I think it’s pretty unacceptable….. (yeah yeah, look at me – complaining about free, open-source software)

    I just installed WP 2.1.3 for a friend/client for a new site, and it’s embarassing to have to tell him that he has to use IE to get all the functionality to work correctly.

    ok – i take back (nearly) all the bad things I said about WordPress.

    This is (at least in my case) a greasemonkey user script problem. If you are having this problem, disable greasemonkey and see if it goes away. If it does, re-enable GreaseMonkey and start disabling all your user scripts. The one that was causing the problem for me was “Force Wrap”, which forces wrapping of long text strings in the browser. You can either disable the script, or you can set it to exclude your wordpress site.

    I’m having the same problem. I upgraded yesterday, made one simple adjustment and then “POOF!” The editor was gone.

    I disabled all plugins; I reinstalled a clean editor; I tried installing the older editor (which happens to work on one of my other sites with no problem); I ultimately had to find a plugin, which does the trick, but I would prefer that the packaged one worked. *sigh*

    Moderator Andrew Ozz

    @azaozz

    If you’re using FF with the NoScript plugin, you have to update NoScript…
    http://wordpress.org/support/topic/107146?replies=15

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Rich Text Editor Problem – 2.1’ is closed to new replies.
Skip to toolbar