Support » Plugin: Rich Text Excerpts » Rich Text editor – Experts not showing on pages

  • Resolved beforeplastic

    (@beforeplastic)



    Hello,

    I just install the Rich Text editor to enable me to include Exerpts on pages and posts so the code doesn’t display in search results.

    In settings there is only a Posts and Products option but on the Rich Text description it says it works in pages. Do I need a different version of the plugin?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author bjorsq

    (@bjorsq)

    No, you need to enable excerpts on pages (this is not enabled by default). One way of doing this is to put the following in your theme functions file.

    
    add_post_type_support( 'page', 'excerpt' );
    

    Thank you. Can I find that in the child theme?

    Plugin Author bjorsq

    (@bjorsq)

    If you put it in the Child Theme’s functions.php file it should work.

    I added this code to my child them function file but it didn’t work.

    Plugin Author bjorsq

    (@bjorsq)

    Are you certain? When you go to edit the page, is the excerpt editor shown at all? Either on the page or as a checkbox in screen options?

    I don’t see it. Maybe I’m missing it. Happy to provide credentials if this is private.

    I got it to work! yay

    Plugin Author bjorsq

    (@bjorsq)

    If you look at the Rich Text Excerpt plugin settings, it should now have an option to enable the plugin for pages. If this option isn’t present, your installation still does not support excerpts for pages. If you have added post type support for excerpts to pages in your child theme as above, the only conclusion I can draw is that something else (another plugin or the parent theme) is removing support for excerpts on pages after your child theme adds it.

    Plugin Author bjorsq

    (@bjorsq)

    Nice one!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Rich Text editor – Experts not showing on pages’ is closed to new replies.