RDFa Breadcrumb
[resolved] rich snippet tool missing out last item (3 posts)

  1. matt solomon
    Posted 2 years ago #

    Hi this plugin is great and as soon as i coded it into my site it worked perfectly well done!

    just a question

    lets say my page was http://www.domain.com/page1/page2/page3/

    the rich snippet checker is only showing this

    http://www.domain.com > Page1 > Page 2

    it doesn't show the last item?

    so for example my services design, graphics, hosting, all show in the rich snippet tool as '> services'

    do you know why?


  2. Nitin Yawalkar
    Plugin Author

    Posted 2 years ago #

    Its because of the last item is not linked.

    I will fix it in the next update with a check box for turning on the last item to be linked or not.

    Till, you may try this:

    • Go to Dashboard -> Plugins -> Editor and choose the RDFa-Breadcrumb from plugins dropdown list.
    • Now Open the file rdfa-breadcrumbs.php
    • Go to line no. 147 or find the following code:
      $item['last'] = get_the_title();
    • Now, replace it with the following code:
      $item['last'] = '<span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="' . get_permalink() ) . '">' . get_the_title() ) . '</a></span>';
    • If this doesn't work, please replace it with the original and wait till the next update.


  3. matt solomon
    Posted 2 years ago #

    this actually isnt to do with the last item linking as i have tried this in a previous site.

    This is to do with the way google displays breadcrumbs in its search. It doens't link the past page because the main search result is the last page. the breadcrumbs are the pages above

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • RDFa Breadcrumb
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.