Support » Plugin: Yoast SEO » Rich pins not pulling article name

  • Hello,

    My name is Angela, and my website is I’m currently running the Simple Mag theme by Themesindep and using the latest version of Yoast SEO.

    Up until about a week ago when I updated WordPress and Yoast, my rich pins have stopped working. When I run my URLs through the rich pins validator, it tells me my rich pins have been approved and there is a green checkbox besides everything except for the article name.

    My open graph data is added and I’ve already contacted pinterest who were unable to provide any support.

    Here is an article URL:

    What could be the problem? Any help would be much appreciated!!


Viewing 10 replies - 1 through 10 (of 10 total)
  • bN


    I am also having this issue, up until a week or so ago it pulled the article name, now it just shows my name which im guessings it pulling the author name through.



    Is it possible its something to do with yoast as that is where my rich pin info is coming from I believe.

    Not Yoast releated. Pinterest has been having issues; and sometimes I have to hit reload on the saved item from edit screen and title will appear. This started October 1, regardless of theme, or Yoast version.

    Pinterest reads the meta data; so if it’s in your head, it should work. That’s all Yoast does.

    If you have errors on your page, however (do F12 in console view in Chrome), that can impact it. Or if your page “times out” when they try to grab info properly.

    Upshot: we’ve been seeing this behavior randomly since about Oct 1 as we share multiple items each day from our news network, so pretty much on top of ‘weirdness’ with social accounts.

    Not sure that helps anybody, but also you can test your post with Pinterest debugger as well to see if any issue there.

    LOL … case in point; error I just got on Pinterest – unrelated to our site(s);

    Error 503 first byte timeout
    first byte timeout
    Guru Mediation:
    Details: cache-lax8635-LAX 1476815008 36731692
    Varnish cache server


    Our server is experiencing a mild case of the hiccups.
    We've reported it to the team.
    Try again?
    • This reply was modified 6 years, 5 months ago by neotrope.


    Thanks for getting back to me. I will try the suggestions and hope that Pinterest gets it sorted!

    Thread Starter angelabkr


    That is really frustrating!

    All my rich pins have disappeared now and Pinterest can’t provide any support on the issue.

    It doesn’t have any issues pulling anything other than the article name. Everything else is working perfectly!

    Is there anything else I could do to sort the issue or go to for help? Rich pins drive a lot of my traffic so this has been quite a big problem for me!

    I’m also having trouble, but with configuring the Rich Pins for I have everything set up in Yoast – all the meta data boxes are checked and I enabled Facebook Open Graph option. But still I get this message: The data we scraped from your site could not be validated. Please make sure all required tags are present and you aren’t serving different pages depending on different user agents.

    I get the red exclamation mark next to Rich Pins Enabled. Super frustating, because I tried everyhting :(. Hope it will work soon..

    Thread Starter angelabkr


    I’m having a bit of a different issue, my rich pins are all enabled and there is a green tick next to everything except the article name. Have you tried contacting Pinterest about your issue?

    Hi Angela, yes I tried but the contact form on Pinterest support is glitching.. Maybe they don’t want it to work :’) But I will keep trying

    We are having the same issue on our site. We’ve had Rich Pins validated for some time now, but they’ve stopped working. When I put any URL through their Rich Pin validator it says our site is validated for Rich Pins (green check) but that it can’t retrieve any data about Site Name or Favicon. I’ve submitted a help request a couple of times through Pinterest but having heard anything from them. :/

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Rich pins not pulling article name’ is closed to new replies.