Support » Fixing WordPress » RewriteEngine not working

  • Anonymous

    Hi there,
    Ok, I managed to install WP on another server.
    Now I’m trying to setup nice URL but I don’t manage. I created a .htaccess file inside my weblog’s directory but I didn’t manage to make it work. Putting and removing lines I’ve realised that the problem comes when I switch on RewriteEngine.
    If .htaccess is empty everything works fine. But if I add RewriteEngine On the server stops working and displays a 500 Internal Error.
    mod-rewrite is on because I start .htaccess with <IfModule mod_rewrite.c>, so the module is there…
    Thanks for your help! 🙂
    Anyone know where’s the problem?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Cena

    (@cena)

    It does mean that mod_rewrite isn’t available for some reason. This is a problem on your server’s end, so best to check with them.

    Armitage

    (@armitage)

    A friend of mine runs the server, he can’t seem to figure it out… he’s been messing with it for sometime… any apache guru’s out there have any ideas?

    carthik

    (@carthik)

    Can you please copy and paste the contents of your .htaccess file here? You can use the to post code.

    Armitage

    (@armitage)

    Anyone know any reason why mod_rewrite compile but now work?

    Double check that you have your base path set to a folder above or equal to where your website’s path. Most of the time, people will over look this and mod_rewrite will load but won’t do anything. You might double check your directory options too.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘RewriteEngine not working’ is closed to new replies.