Support » Plugin: Translate Multilingual sites - TranslatePress » rewritebase .htaccess

  • Resolved leggedy

    (@leggedy)


    Hi there,

    I believe this was asked numerous time, but I could not find a fix for this.

    Below htaccess cond is stable;

    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    Each time the theme is updated or a new plugin installed;

    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /en/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /en/index.php [L]

    the /(lang)is added and causes 404 error.

    Anyway to fix this?

    pretty permalink is enabled.

Viewing 1 replies (of 1 total)
  • Plugin Support Dragos

    (@dragosvrejiu)

    Hello,

    TranslatePress should not modify .htaccess in any way but this issue has been reported by a few of our users in the past.

    We’ll look over it and get back to you once progress has been made.

    Best regards,

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.