Support » Plugin: WP Super Cache » “Rewrite rules must be updated” message on WordPress 4.9

  • I have two blogs running WordPress with WP Super Cache that, immediately after upgrading WordPress to 4.9, started reporting the message “Rewrite rules must be updated” in the Super Cache section of the admin. I tried to apply the change automatically, and received the following message:

    The plugin could not update /home/hyperionktv/hyperborea.org/journal/.htaccess file: WordPress rules empty.

    The rules *aren’t* empty – both the Super-Cache and WordPress rules are present in .htaccess. And in fact the rules in .htaccess are identical to the ones that the Super Cache admin page is telling me I need to add!

    But I wonder if some change in WordPress is preventing the plugin from finding them.

    Possibly relevant: Both of these blogs have a *lot* of rules in .htaccess before they even get to the WP Super-Cache or WordPress rules. Mostly redirects for old permalink structures and (re)moved posts.

    Super-Cache does seem to be working still, but it’s still telling me I need to update the rewrite rules.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Same thing happened to me. After the 4.9 update. WP Super cache plugin. But it seems that the plugin itself works OK.

    • This reply was modified 8 months, 1 week ago by  ricchezza.

    Same here… and I don’t want to hear it from a senior fellow who says we should all create our own threads. Why? So we can have an entire page of them?

    I also noticed that I cannot effect change to the mode the plugin is in.

    If it is on, I cannot turn it off. If it is off, I cannot turn it on.

    It will say it worked, but reload the page and it is set to whatever it was set to before checking/unchecking the box.

    Saša

    (@stodorovic)

    It seems as an issue in WordPress 4.9. When I copied function extract_from_markers from WP 4.8.3, it works correctly.

    I’m guessing that’s related to Changeset 41928. I’ll try to find out more details.

    Saša

    (@stodorovic)

    It’s confirmed as bug in WordPress – https://core.trac.wordpress.org/ticket/42579. It’ll be fixed in WP 4.9.1.

    G P

    (@wetapplemedia)

    Same situation here.
    .htaccess files exist, are writable, and have the correct data in them.
    Error message still persists.

    danescobar

    (@danescobar)

    Same here, glad to know the plugin works after manually adding the code to both .htaccess. Even though it display that error message. Thanks guys.

    Also a small question. I use Jetpack mobile theme. Is is better to keep the mod_rewrite method or do I activate Jetpack mobile support in the Plugins tab thus activating the PHP method of caching, i.e. “Simple” method?

    Have a great week.

    dariocoutinho

    (@dariocoutinho)

    Thanks Saša (@stodorovic)

    still happening

    I’m seeing this again after upgrading to 1.6.0 today. I haven’t been seeing it for a while. This is on WordPress 4.9.5.

    G P

    (@wetapplemedia)

    I am also seeing this again on WordPress 4.9.5 with WP Super Cache 1.6.0.

    I checked the .htaccess file and it did update the code in it successfully (with the new changed code from 1.6.0) but the notice still appears in the settings pages as if it wasn’t updated yet.

    This bug is happening again in WordPress version 4.9.6 working with WP Super Cache version 1.6.1.

    Anyone knows how to fix this issue?

    Same here with WP 4.9.6 and WP Super Cache 1.6.1.

    Link my avatar with my info

    I wonder why the plugin authors decided to remain mute in the face of bug report like this.
    Does it mean they no longer care or what?

    Am also having this error report on my admin.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.