Support » Plugin: WP Offload Media Lite for Amazon S3, DigitalOcean Spaces, and Google Cloud Storage » Rewrite CNAME URLs to https://s3.amazonaws.com?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The rewrite rule won’t work because your assets are using a CNAME which points directly to S3, so the .htaccess rules are never triggered because those requests don’t hit your server.

    Unfortunately if you want to continue masking the S3 URL you will need to use a CDN, because S3 doesn’t support custom domains over HTTPS. It’s possible to use CloudFlare’s free CDN as detailed in this article:

    https://deliciousbrains.com/wp-offload-s3/doc/cloudflare-setup/

    I don’t care about masking the S3 URL, I just want the files served by https so that users don’t receive mixed content warnings.

    Thank you for your response A5hleyRich – I guess I will have to learn about Cloudflare or CloudFront after all – I was hoping there was an easier way.

    • This reply was modified 1 year, 5 months ago by  JohnP.

    If you’re not concerned about masking the URL you can disable the ‘Custom domain’ and enable ‘Force HTTPS` in WP Offload S3 and the links will update accordingly.

    https://deliciousbrains.com/wp-offload-s3/doc/settings/

    That’s great news, and it worked!

    I’ve got the CNAME routed through Cloudflare but it’s not doing anything.

    I was beginning to think I would have to edit the database, so your advice is very welcome.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Rewrite CNAME URLs to https://s3.amazonaws.com?’ is closed to new replies.